Введение

BSOD

Содержание

Оффлайн версия инструкций по устранению неполадок при возникновении Blue Screen Of Death (BSOD) размещенных на сайте bsod.oszone.net которые были собраны по материалам базы знаний Microsoft и центра MSDN.

Рекомендовано при поиске информации по BSOD обращать внимание в первую очередь на значение следующее за номером, а не столько на сам номер ошибки. В системах Windows XP, Windows 2000 и Windows NT номера ошибок могут отличаться при совпадении значений.

Обращайте также внимание на описания и решения как для своей версии Windows так и для двух остальных так как все три системы имеют много общего и решения могут быть если не одинаковыми, то схожими.
В случае если предоставленной здесь информации оказалось недостаточно для решения вашей проблемы вы можете обратиться с вопросом в эту тему форума OSzone.net.

Список BSOD

0x00000001: APC_INDEX_MISMATCH

0x0000000A: IRQL_NOT_LESS_OR_EQUAL

0x0000000D: MUTEX_LEVEL_NUMBER_VIOLATION

0x0000001E: KMODE_EXCEPTION_NOT_HANDLED

0x00000020: KERNEL_APC_PENDING_DURING_EXIT

0x00000023: FAT_FILE_SYSTEM

0x00000024: NTFS_FILE_SYSTEM

0x0000002A: INCONSISTENT_IRP

0x0000002B: PANIC_STACK_SWITCH

0x0000002E: DATA_BUS_ERROR

0x00000035: NO_MORE_IRP_STACK_LOCATIONS

0x00000036: DEVICE_REFERENCE_COUNT_NOT_ZERO

0x0000003E: MULTIPROCESSOR_CONFIGURATION_NOT_SUPPORTED

0x0000003F: NO_MORE_SYSTEM_PTES

0x00000040: TARGET_MDL_TOO_SMALL

0x00000041: MUST_SUCCEED_POOL_EMPTY

0x00000044: MULTIPLE_IRP_COMPLETE_REQUESTS

0x00000048: CANCEL_STATE_IN_COMPLETED_IRP

0x0000004C: FATAL_UNHANDLED_HARD_ERROR

0x0000004D: NO_PAGES_AVAILABLE

0x0000004E: PFN_LIST_CORRUPT

0x00000050: PAGE_FAULT_IN_NONPAGED_AREA

0x00000051: REGISTRY_ERROR

0x00000067: CONFIG_INITIALIZATION_FAILED

0x00000069: IO1_INITIALIZATION_FAILED

0x00000071: SESSION5_INITIALIZATION_FAILED

0x00000073: CONFIG_LIST_FAILED

0x00000074: BAD_SYSTEM_CONFIG_INFO

0x00000075: CANNOT_WRITE_CONFIGURATION

0x00000076: PROCESS_HAS_LOCKED_PAGES

0x00000077: KERNEL_STACK_INPAGE_ERROR

0x00000079: MISMATCHED_HAL

0x0000007A: KERNEL_DATA_INPAGE_ERROR

0x0000007B: INACCESSIBLE_BOOT_DEVICE

0x0000007D: INSTALL_MORE_MEMORY

0x0000007E

0x0000007F: UNEXPECTED_KERNEL_MODE_TRAP

0x00000085: SETUP_FAILURE

0x0000008B: MBR_CHECKSUM_MISMATCH

0x0000008E

0x0000008F: PP0_INITIALIZATION_FAILED

0x00000090: PP1_INITIALIZATION_FAILED

0x00000092: UP_DRIVER_ON_MP_SYSTEM

0x00000093: INVALID_KERNEL_HANDLE

0x00000096: INVALID_WORK_QUEUE_ITEM

0x00000097: BOUND_IMAGE_UNSUPPORTED

0x00000098: END_OF_NT_EVALUATION_PERIOD

0x0000009C: MACHINE_CHECK_EXCEPTION

0x0000009F: DRIVER_POWER_STATE_FAILURE

0x000000B4: VIDEO_DRIVER_INIT_FAILURE

0x000000BE: ATTEMPTED_WRITE_TO_READONLY_MEMORY

0x000000C1: SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION

0x000000C2: BAD_POOL_CALLER

0x000000C5: DRIVER_CORRUPTED_EXPOOL

0x000000D1: DRIVER_IRQL_NOT_LESS_OR_EQUAL

0x000000E3: RESOURCE_NOT_OWNED

0x000000EA: THREAD_STUCK_IN_DEVICE_DRIVER

0x000000ED: UNMOUNTABLE_BOOT_VOLUME

0xC0000218: UNKNOWN_HARD_ERROR

0xC000021A: STATUS_SYSTEM_PROCESS_TERMINATED

0xC000026C

Использование материалов данного файла или сайта bsod.oszone.net без согласия администрации сайта запрещено.

© Все права защищены OSzone.net 2001-2006


0x00000001: APC_INDEX_MISMATCH
Внутренняя ошибка ядра (kernel).

Ошибка зачастую означает, что не соответствует число KeEnterCriticalRegion числу KeLeaveCriticalRegion в файловой системе.

Проблема связана чаще всего с неполадкой в драйверах, нехваткой оперативной памяти или места на жестком диске.


[0x0000000A: IRQL_NOT_LESS_OR_EQUAL] общий обзор
STOP 0x0000000A показывает, что процесс ядра или драйвер пытались обратиться к памяти, к которой у них нет разрешения обращаться.
Самая распространенная причина - это некорректный или повреждённый указатель (pointer), который указывает на неправильный участок в памяти. Указатель (pointer) - это переменная, которая используется программой, для указания на блок в памяти. Если переменная имеет неправильное значение, тогда программа пытается обратиться к памяти, к которой у неё нет прав обращаться. Когда это происходит в программе пользователя, она генерирует нарушение доступа. Когда это происходит в режиме ядра, она генерирует STOP 0x0000000A сообщение.
Одна из самых часто возникающих ошибок Windows NT - STOP 0x0000000A. Этот STOP может быть вызван как Программным Обеспечением, так и проблемой с оборудованием. Для выявления причин вы должны разобрать этот STOP, используя дебагер. Тем не менее, некоторые выводы можно сделать, рассмотрев параметры STOP сообщения и сообщения сопутствующего этот STOP.

Параметры:
1 - адрес, по которому выполнено ошибочное обращение
2 - IRQL, который использовался для обращения к памяти
3 - тип доступа к памяти: 0 = операция чтения, 1 = операция записи
4 - адрес инструкции, которая затребовала доступ к памяти по адресу

Примечание: Наиболее частая причина возникновения - драйвер устройства использует неверный адрес. Некоторые из них в Windows XP вы можете обнаружить, используя утилиту verifier.exe: Start (Пуск) => Run (Выполнить) => verifier.exe

Дополнительная информация:
STOP 0x0000000A показывает, что процесс ядра или драйвер пытались обратиться к памяти, к которой у них нет разрешения обращаться.
Самая распространенная причина - это некорректный или повреждённый указатель (pointer), который указывает на неправильный участок в памяти. Указатель (pointer) - это переменная, которая используется программой, для указания на блок в памяти. Если переменная имеет неправильное значение, тогда программа пытается обратиться к памяти, к которой у неё нет прав обращаться. Когда это происходит в программе пользователя, она генерирует нарушение доступа. Когда это происходит в режиме ядра, она генерирует STOP 0x0000000A сообщение.
Чтобы выявить какой процесс или драйвер пытался обратиться к неверному адресу памяти, посмотрите на параметры, указанные на STOP экране. Например, в этом STOP сообщении:
STOP 0x0000000A(0xWWWWWWWW, 0xXXXXXXXX, 0xYYYYYYYY, 0xZZZZZZZZ)
IRQL_NOT_LESS_OR_EQUAL
** Адрес 0xZZZZZZZZ основывается на -
Четыре параметра имеют следующие значения:
0xWWWWWWWW указаный адрес памяти, который не является корректным для данного обращения
0xXXXXXXXX IRQL прерывание, которое требуется, чтобы иметь доступ к памяти
0xYYYYYYYY Тип доступа, 0=Чтнение, 1=Запись
0xZZZZZZZZ адрес инструкции, обратившияся к памяти, указаной в первом параметре
Если последний параметр (0xZZZZZZZZ) указывает на область адресов системных устройств, значит, драйвер какого устройства был запущен во время ошибки. Этот драйвер обычно указан на третьей линии STOP экрана:
** Адрес 0xZZZZZZZZ основывается на -
Если специфический драйвер, сделайте поиск в Microsoft Knowledge Base на слово "0x0000000A" и имя драйвера. Если вы не найдёте никаких подходящих статей, свяжитесь с Microsoft Product Support.

Общие способы устранения возникновения ошибки 0x0000000A: IRQL_NOT_LESS_OR_EQUAL

0x0000000A: IRQL_NOT_LESS_OR_EQUAL во время установки системы

Применяется к семьям систем:
  • Windows NT
  • Windows 2000
  • Windows XP

1. Проверьте совместимость вашего оборудования с устанавливаемой системой.
Для этого обратитесь к последней версии Списка Совместимости Оборудования (Hardware Compatibility List (HCL)) для вашей системы:
http://www.microsoft.com/whdc/hcl/default.mspx

Если вашего оборудования нет в списке, то приведённые ниже шаги могут помочь устранить проблему.

2. Вовремя установки, когда на экране появиться сообщение о проверке аппаратной конфигурации компьютера (Setup is inspecting your computer`s hardware configuration), нажмите F5. После приглашения, укажите подходящую конфигурацию компьютера и hardware abstraction layer (HAL). Например, для компьютера с одним процессором укажите «Стандартный компьютер» (Standard PC).

3. Отключите следующие функции в CMOS установках вашего компьютера. Для дополнительной информации, как это сделать, обратитесь к документации сопровождающей ваше оборудование (пр.: материнская плата):

  • Любое кэшироване, включая кэширование второго урованя процессора (L2), кэш BIOSа, внутреннее и внешнее кэширование и кэш записи на контроллерах диска.
  • Любую "теневую" память (shadowing)
  • Plug and Play
  • Любое антивирусное обеспечение на уровне BIOS.

4. Отсоедените все адаптеры и оборудование, которое не является необходимым для установки Windows, включая:

  • сетевой адаптер (network adapter)
  • Внутренний модем
  • Звуковую карту
  • Лишние жесткие диски и CD-ROM`ы

5. Если вы используете SCSI адаптер, воспользуйтесь следующими методами. Для допольнительной информации обратитесь к документации оборудования.

  • Убедитесь, что вы используете новейшие версии драйверов
  • Отключите синхронную передачу данных (sync negotiation) на SCSI контроллере
  • Отключите всё SCSI устройства, за исключением жёсткого диска, на который осуществляется установка.

6. Если вы используете IDE устройства, то воспользуетесь следующими методами. Для дополнительной информации обратитесь к документации оборудования.

  • Установите встроенный IDE канал на Первичный (Primary only)
  • Убедитесь, что Master/Slave/Only установки верны для IDE устройств на вашем компьютере.
  • Отключите всё IDE устройства, за исключением жёсткого диска, на который осуществляется установка.

7. Проверьте модули оперативной памяти (RAM) на компьютере. Для дополнительной информации обратитесь к документации оборудования.

  • Удалите все несоответствующие чипы О.П., так чтобы все чипы работали на одной скорости (например на 60ns или 70ns наносекундах)
  • Протестируйте модули памяти специальными программами (пр.: memtst86) и удалите неисправные
  • Замените модули на рабочие

8. Обратитесь к производителю компьютера или материнской платы для помощи в следующих ситуациях:

  • Информация о уже известных проблемах с оборудованием и по их устранению
  • Диагностика компьютера
  • Обновление системного BIOS, если необходимо

0x0000000A: IRQL_NOT_LESS_OR_EQUAL на уже работающей системе

Применяется к семьям систем:
  • Windows NT
  • Windows 2000
  • Windows XP

Проверка драйверов и программного обеспечение третьей стороны.
Если вы только что установили новую программу или драйвера, попробуйте отключить их.

Если же вы не можете загрузить Windows после того как вы установили новую программу или драйвера, воспользуетесь приведёнными ниже методами для восстановления работы системы:

1. Воспользуйтесь восстановлением на последнюю рабочую конфигурацию системы (Last Known Good configuration)
Для этого во время загрузки системы нажмите F8 и выберите соответствующую опцию из предлагаемого меню.
Для дополнительной информации обратитесь к следующей статье:
307852 (http://support.microsoft.com/kb/307852/) How to start your computer with Last Known Good Configuration

2. Восстановите установку Windows, использую следующие методы:

  • Любое антивирусное обеспечение на уровне BIOS
  • Загрузитесь с установочного диска или дискет:
    Когда установка вам предложит следующие опции:
    To set up Windows XP now, press ENTER.
    To repair a Windows XP installation using Recovery Console, press R.
    To quit Setup without installing Windows XP, press F3

    Нажмите Enter
    Подтвердите соглашение
    Следующим шагом установка проверит жёсткий диск на наличие ОС и предложит вам сделать восстановление, нажмите R для начала восстановления.

3. Воспользуйтесь Откаткой Драйверов (Roll Back Driver)
Для дополнительной информации обратитесь к следующей статье:
283657 (http://support.microsoft.com/kb/283657/) How to use the Roll Back Driver feature

4. Воспользуйтесь Консолью Восстановления
Для дополнительной информации обратитесь к следующей статье (Windows XP):
307654 (http://support.microsoft.com/kb/307654/) How to install and use the Recovery Console in Windows XP

5. Если система установлена на файловой системе FAT, загрузитесь в MS-DOS и переименуйте неисправный драйвер или программу.

Проверка установленного оборудования

Если вы только что установили новое оборудование, то отсоедините его и воспользуйтесь приведёнными ниже методами для решения проемы:
  • Обновите драйвера до последней доступной версии
  • Обратитесь к производителю, чтобы узнать о уже известных проблемах
  • Воспользуйтесь диагностикой оборудования
  • Просмотрите логи и Журнал Событий (event viewer) на предмет информации о каких либо неработающих драйверах или программах.

Если ничего из изложенного выше вам не подошло/не помогло, обратитесь к нашим статьям для более специфических случаев ниже.

  • 0x0000000A Возникновение ошибки при переходе (Upgrade) на Windows XP
  • 0x0000000A Возникновение ошибки при переходе из AC на DC питание на ноутбуке
  • 0x0000000A при "Быстром переключении пользователей", Windows XP
  • 0x0000000A: IRQL_NOT_LESS_OR_EQUAL по причине Pqv2i.sys
  • 0x0000000A (0x00000806, 0x00000002, 0x00000000, 0x804fd3aa) IRQL_NOT_LESS_OR_EQUAL на Windows Server 2003


[0x0000000A] Возникновение ошибки при переходе (Upgrade) на Windows XP
Одна из самых часто возникающих ошибок Windows NT - STOP 0x0000000A. Этот STOP может быть вызван как Программным Обеспечением, так и проблемой с оборудованием. Для выявления причин вы должны разобрать этот STOP, используя дебагер. Тем не менее, некоторые выводы можно сделать, рассмотрев параметры STOP сообщения и сообщения сопутствующего этот STOP.

Параметры:
1 - адрес, по которому выполнено ошибочное обращение
2 - IRQL, который использовался для обращения к памяти
3 - тип доступа к памяти: 0 = операция чтения, 1 = операция записи
4 - адрес инструкции, которая затребовала доступ к памяти по адресу

Примечание: Наиболее частая причина возникновения - драйвер устройства использует неверный адрес. Некоторые из них в Windows XP вы можете обнаружить, используя утилиту verifier.exe: Start (Пуск) => Run (Выполнить) => verifier.exe

Возникновение ошибки при переходе (Upgrade) на Windows XP:

При обновлении с Windows 98 или Windows МЕ на Windows ХР может возникнуть эта ошибка.
Ошибка чаще возникает из-за несовместимого оборудования или драйвера.

Решение:
1. Перезагрузите компьютер и посмотрите - предложит ли вам вернуться на предыдущую операционную систему. Если да, то выбирайте эту опцию. Если нет, то пропустите пункт 2 и переходите на пункт 3.
2. Когда компьютер загрузиться в Windows 98 или Windows МЕ, удалите любые антивирусы и сторонние загрузчики (такие, как Roxio GoBack и др.), после этого "вычистите загрузчик", используя информацию следующих статей:
267288 чистка загрузчика в Windows Millennium Edition
192926 чистка загрузчика в Troubleshooting for Windows 98
Потом перезагрузите компьютер и попытайтесь сделать обновление снова. Если и после этого не удастся это сделать, то скорее всего проблема в оборудовании.
3. Отключите все внешние устройства и сетевое оборудование компьютера (USB оборудование, принтеры, модемы и сетевые карты и т.д.), оставьте минимум (монитор, видео карта, клавиатура и мышь и CD-ROM)
4. Если и после этого Вы продолжаете получать эту ошибку, возможно, Вам необходимо обновить BIOS. Свяжитесь с производителем материнской платы и выясните, если есть какие-либо обновления для BIOS.


[0x0000000A] Возникновение ошибки при переходе из AC на DC питание на ноутбуке
Одна из самых часто возникающих ошибок Windows NT - STOP 0x0000000A. Этот STOP может быть вызван как Программным Обеспечением, так и проблемой с оборудованием. Для выявления причин вы должны разобрать этот STOP, используя отладчик. Тем не менее, некоторые выводы можно сделать, рассмотрев параметры STOP сообщения и сообщения сопутствующего этот STOP.

Параметры:
1 - адрес, по которому выполнено ошибочное обращение
2 - IRQL, который использовался для обращения к памяти
3 - тип доступа к памяти: 0 = операция чтения, 1 = операция записи
4 - адрес инструкции, которая затребовала доступ к памяти по адресу

Примечание: Наиболее частая причина возникновения - драйвер устройства использует неверный адрес. Некоторые из них в Windows XP вы можете обнаружить, используя утилиту verifier.exe: Start (Пуск) => Run (Выполнить) => verifier.exe

STOP 0x0000000A при переходе с AC на DC питание:

Применяется к следующим системам:
  • Windows XP

После прехода из AC питания на вашем ноутбуке на DC появляется следующее сообщение об ошибке:
STOP: 0x00000050 (xxxxxxxxx, xxxxxxxxxxxx, xxxxxxxxxx, xxxxxxxxxx)
PAGE_FAULT_IN_NON-PAGED_AREA
В большенстве случаев возникает, когда вы пытаетесь отключить/подключить к питанию ноутбук, находящийся в спящем режиме (Standby mode).
Примечание. Четыре параметра в составе сообщения могут различаться в зависимости от конфигурации ноутбука.

Решение:
Для решения проблемы установите последний пакет обновлений.
Последний пакет обновлений должен быть с приведёнными ниже атрибутами или позже:

Date | Time | Version | Size | File name | Platform
12-Feb-2002 | 16:42 | 5.1.2600.28 | 32,384 | Amdk6.sys | i386
12-Feb-2002 | 16:42 | 5.1.2600.28 | 32,896 | Amdk7.sys | i386
12-Feb-2002 | 16:42 | 5.1.2600.28 | 31,744 | Crusoe.sys | i386
24-Jan-2002 | 14:23 | 5.1.2600.28 | 1,842,176 | Ntkrnlmp.exe | i386
24-Jan-2002 | 14:23 | 5.1.2600.28 | 1,896,960 | Ntkrnlpa.exe | i386
24-Jan-2002 | 14:23 | 5.1.2600.28 | 1,870,336 | Ntkrpamp.exe | i386
24-Jan-2002 | 14:23 | 5.1.2600.28 | 1,874,688 | Ntoskrnl.exe | i386
12-Feb-2002 | 16:43 | 5.1.2600.28 | 37,248 | P3.sys | i386
12-Feb-2002 | 16:42 | 5.1.2600.28 | 30,976 | Processr.sys | i386
08-Jan-2002 | 16:12 | 5.1.2600.27 | 5,724,160 | Ntkrnlmp.exe | Itanium 64-bit
08-Jan-2002 | 16:12 | 5.1.2600.27 | 5,667,328 | Ntoskrnl.exe | Itanium 64-bit
08-Jan-2002 | 16:14 | 5.1.2600.27 | 60,544 | Processr.sys | Itanium 64-bit


[0x0000000A] при "Быстром переключении пользователей", Windows XP
Возникновение ошибки при "Быстром переключении пользователей" (Fast Switch Between Users)

http://support.microsoft.com/kb/314063/en

IRQL_NOT_LESS_OR_EQUAL
Stop 0x0000000A (0x0227001d, 0x00000002, 0x00000000, 0x804eba3a)

первый параметр может меняться в зависимости от компьютера.
Проблема может появиться, если вы используете ПО и драйвера Netropa Corporation для клавиатуры, чтобы добавить ей дополнительные функции.

Решение: обновите драйвера клавиатуры. Драйвера Netropa Corporation можно найти по адресу: http://www.netropa.com/download/mmkbd/download.html
Вы можете выяснить, почему соответствующая программа не завершилась корректно.
Для этого:
Старт (Start) => Выполнить (Run) => msinfo32.exe => Среда Программного Обеспечения (Software Environment) => Системная Информация (System Information) => просмотрите список программ, выясните, которая относиться к клавиатуре. Обычно эта программа загружается со следующей ветки реестра:
HKEY_LOCAL_MACHINE\Software\Microsoft\ Windows\CurrentVersion\Run
После того, как вы обнаружили программу, которая не завершилась корректно, используйте Autodump + утилиту, чтобы сгенерировать код ошибки.


[0x0000000A: IRQL_NOT_LESS_OR_EQUAL] по причине Pqv2i.sys
Применяется к следующим системам:
  • Windows XP
  • Windows Server 2003
  • Windows 2000
  • Windows Small Business Server 2003
  • Windows Small Business Server 2000

На системах перечисленных выше может появиться стоп 0x0000000A при одном из следующих симптомов:

Компьютер может перестать отвечать на ваши действия и появиться следующее сообщение об ошибке:
STOP 0x0000007b (p1, 0xc0000102, p3, p4) ERROR_UNHANDLED_ERROR
Примечание: Второй параметр (0xc0000102) так же может быть 0xc000009c. Параметры 1, 3 и 4 могут быть любыми.

STOP 0x0000000a (0xbb693f7c, 0x00000002, 0x00000001, 0x8006543a) IRQL_NOT_LESS_OR_EQUAL STOP 0x0000000a (0x00000016, 0x0000001c, 0x00000000, 0x80432ed0) IRQL_NOT_LESS_OR_EQUAL

Компьютер может перестать отвечать на ваши действия и появиться следующее сообщение об ошибке во время того, как Windows пытается подключить a volume that is in a cluster on your Windows 2000 Advanced Server-based computer:
STOP 0x0000001e (0xc0000005, 0xbf89e3f1, 0x00000000 0x0000002e)

Компьютер может перестать отвечать на ваши действия и появиться следующее сообщение об ошибке, когда вы пытаетесь запустить установку Windows Small Business Server 2003, чтобы обновить ваш Small Business Server 2000 компьютер:
STOP 0x000000ED (0x89AE1B28, 0xC000009C, 0x00000000, 0x00000000) UNMOUNTABLE_BOOT_VOLUME

Причина:
Причиной являются некоторые версии Pqv2i.sys драйвера, входящего в состав V2i Protector 2.0 от Symantec.

Решение:
Для решения проблемы обновите программное обеспечение Symantec.
Для этого обратитесь на сайт Symantec


[0x0000000A IRQL_NOT_LESS_OR_EQUAL] на Windows Server 2003
0x0000000A (0x00000806, 0x00000002, 0x00000000, 0x804fd3aa) IRQL_NOT_LESS_OR_EQUAL на Windows Server 2003

Применяется к следующим системам:

  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition

Симптомы:
Компьютер, на котором установлена система из симейства Microsoft Windows Server 2003, может неожидано перестать отвечать на действия пользователя, так же вы можете получить следующее сообщение об ошибке:
Stop 0x0000000A (0x00000806, 0x00000002, 0x00000000, 0x804fd3aa) IRQL_NOT_LESS_OR_EQUAL
Примечание. Четыре параметра в составе сообщения могут различаться.

Причина:
Такое может произойти, когда система пытается загрузить повреждённый профиль пользователя.

Решение:

Для решения этой проблемы Microsoft выпустила заплатку. Заплатка должна применяться только к системам, указанным выше, и только для решения изложенной проблемы.

Для получения hotfix свяжитесь с Microsoft Product Support Services. Для этого обратитесь к списку телефонов указанных здесь - http://support.microsoft.com/contactus/?ws=support

Примечание: в некоторых ситуациях звонок может быть оплачен Microsoft, если Microsoft Product Support Services определит, что этот заплатка поможет решить описанную вами проблему.

Предпосылки:
Нет.

Информация о файле:
Английская версия файла должна иметь приведённые ниже атрибуты или новее. Не забудьте принять во внимание разницу во времени.

Windows Server 2003, Itanium-based versions

File name | File version | File size | Date | Time | Platform
Ntkrnlmp.exe | 5.2.3790.2571 | 6,487,552 | 16-Nov-2005 | 02:26 | IA-64

Windows Server 2003, x64-based versions

File name | File version | File size | Date | Time | Platform | SP requirement | Service branch
Ntkrnlmp.exe | 5.2.3790.2571 | 4,420,608 | 16-Nov-2005 | 02:27 | x64 | SP1 | SP1QFE
Ntoskrnl.exe | 5.2.3790.2571 | 4,447,232 | 16-Nov-2005 | 02:27 | x64 | SP1 | SP1QFE

Windows Server 2003, 32-bit versions

File name | File version | File size | Date | Time | Platform | SP requirement | Service branch
Ntkrnlmp.exe | 5.2.3790.2571 | 2,455,040 | 16-Nov-2005 | 06:50 | Not Applicable | SP1 | SP1QFE
Ntkrnlpa.exe | 5.2.3790.2571 | 2,269,184 | 16-Nov-2005 | 03:54 | x86 | SP1 | SP1QFE
Ntkrpamp.exe | 5.2.3790.2571 | 2,308,608 | 16-Nov-2005 | 03:54 | Not Applicable | SP1 | SP1QFE
Ntoskrnl.exe | 5.2.3790.2571 | 2,417,152 | 16-Nov-2005 | 06:50 | x86 | SP1 | SP1QFE


0x0000000D: MUTEX_LEVEL_NUMBER_VIOLATION
Попытайтесь установить взаимоисключения, используя файл заголовков NTOSEXEXLEVELS.H
Вы должны найти точки взаимодействия и определить, какие из них пытаются получить доступ к этому уровню в неверной последовательности.

Параметры:
1 - данная нить уровня взаимодействия
2 - уровень взаимодействия пытающийся получить доступ


0x0000001E: KMODE_EXCEPTION_NOT_HANDLED

[0x0000001E: KMODE_EXCEPTION_NOT_HANDLED] общий обзор
Это очень часто встречающаяся ошибка. Обычно второй параметр (адрес) указывает на драйвер или функцию, которая вызвала стоп-экран. Всегда обращайте внимание не только на указанный драйвер, но и на сам адрес или образ, указанный на экране.
Обычно это код исключения 0x80000003. Эта ошибка означает, что прерывание было применено при обращении к памяти, но система всё равно загрузилась с ключом /NODEBUG . Это ошибка не должна появляться слишком часто. Если ошибка появляется постоянно, убедитесь, что отладчик (debugger) подключён и система загружается с /DEBUG ключом.
На системах не относящимся к семье Интел, если адрес исключения 0XBFC0304, ошибка появляется вследствие кэширования процессора. Если ошибка будет появляться снова, свяжитесь с производителями.
Как правило, требуется анализ второго параметра этого сообщения, который указывает на адрес драйвера/функции, которая была причиной проблемы.

Параметры:
1 - код исключительной ситуации
2 - адрес, при обработке которого произошел сбой
3 - параметр 0 исключения
4 - параметр 1 исключения

Решение:

Сообщение указывает на то, что ядро Windows XP Professional обнаружило запрещённую операцию или неизвестную инструкцию процессора. Проблема, которая вызывает сбой такого рода, схожа с той, которая вызывает ошибку 0x0000000A. Так же причиной может быть повреждённая память или нарушенный доступ. Windows XP Professional умеет сам справляться с этой проблемой, если только проблема не захватила и саму "поддержку системы в аварийной ситуации".

Решение:
0х01Е стоп-сообщения обычно появляются после установления неисправных драйверов или системных сервисов, или они могут указывать на проблемы оборудования, такие как память и IRQ конфликты. Если в стоп сообщении указывается список драйверов, отключите/ликвидируйте их. Если удаление программного обеспечения или драйверов решат проблему, то свяжитесь с производителем и выясните на счёт обновлений. Обновлённое ПО особенно важно при использовании мультимедийного ПО, антивирусных программ и СД-записывающих мастеров.
Если в стоп-ошибке упамянается Win32k.sys, проблемой может быть программы "удалённого доступа" третьей стороны. Если такая программа установлена, Вы можете удалить её загрузившись в Безопасном режиме. Если нет, то используя консоль восстановления (Recovery Console) удалите неисправный системный файл. Для большей информации о Безопасном режиме и консоль восстановления, смотрите "Tools for Troubleshooting".
Проблема может возникнуть из-за несовместимости микропрограммного обеспечения. Многие Advanced Configuration and Power Interface (ACPI) проблемы могут решиться с обновлением микропрограммного обеспечения (BIOS).
Так же может помочь чистка диска от ненужных временных файлов (temporary files) и т.п., так как проблема может возникнуть из-за недостаточного места на диске (для виртуальной памяти в том числе). Для этого вы можете использовать утилиту Очистки Диска (Disk Cleanup).

Решения применяемые в наиболее распространенных случаях возникновения ошибки:

0x0000001E: KMODE_EXCEPTION_NOT_HANDLED сообщение от ASPI32.sys

BSOD 0x0000001E при использовании шрифта Bookman Old Style

Возникновение ошибки 0x0000001E KMODE_EXCEPTION_NOT_HANDLED в Windows 2000


[0x0000001E] ошибка в драйвере ASPI32.sys
Применяется к системам:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition

Система выдала сообщение 0x0000001e с указанием Aspi32.sys

Причина::
Эта ошибка спровоцирована тем, что на вашем компьютере установлена старая версия Advanced SCSI Programming Interface (ASPI).

Решение::
Для решения этой проблемы, установите ASPI версии 4.57 или позднее.
Для более подробной информации об обновлении ASPI, обратитесь на официальный сайт Adaptec:
http://www.adaptec.comm

Примечание:
Чтобы установить версии используемого вами ASPI в данный момент, просто посмотрите Свойства файла Aspi32.sys или Aspi.sys


[0x0000001E] при использовании шрифта Bookman Old Style
Если вы используете шрифт Bookman Old Style, и ваш видео драйвер пытается вывести на экран с отрицательным "x", вы можете получить сообщение об ошибке:
STOP 0x0000001E (0xc0000005, 0xfccc6add, 0x00000001, 0x013b8020)
Примечание: 4-ый параметр может меняться, но 2-ой всегда в пределах Vga.dll.
Это может быть исправлено установкой SP6, но это не документиравано. Если нет, не используйте Bookman Old Style font.

Так же плохо написанные программы могут вызвать BSOD 0x0000001E или 0x00000024. Происходит из-за того, что программа открывает много указателей (handles), но никогда не закрывает их и когда вы закрываете программу, то NT пытается закрыт все указатели, но не хватает ресурсов. Программы должны сами их за собой закрывать.
Решения по этому поводу пока у NT нет. Вы можете попробовать закрывать программы почаще, чтобы снизить количество открытых handles.

Применяется:
  • Windows NT Terminal Server
  • Windows 2000 running Terminal Services
Вы получили STOP 0x0000001E, во время распечатки на Hewlett-Packard DesignJet принтере.
Проблема может появиться, если вы используете драйвер Hewlett-Packard DesignJet (HPGL2/RTL) версии 4.4 для Windows NT 4.0 и Windows 2000, потому что драйвер не способен благополучно посылать всплывающие окна на рабочий стол.

Решение:
1. Вы можете избавиться от проблемы, используя драйвер Microsoft, если возможно.
2. так же можно запретить UMPD функцию (User Mode Print Driver) в драйвере:
1. Используйте Regedt32 - HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\print\Printers\<Your Printer Driver>\PrinterDriverData.
2. Удалите значение SPLUserModePrinterDriver.
3. Переименуйте следующие файлы в .OLD_DLL расширение:
%SystemRoot%\System32\Spool\Drivers\W32x86\Ppltumpd.dll
%SystemRoot%\System32\Spool\Drivers\W32x86\2\Hpltumpd.dll
%SystemRoot%\System32\Spool\Drivers\W32x86\3\Hpltumpd.dll
4. Откройте CMD и напечатайте:
net stop spooler
net start spooler


0x0000001E: KMODE_EXCEPTION_NOT_HANDLED

[0x0000001E] на компьютере под управлением Windows 2000

Возникновение ошибки в процессе печати клиента Терминального Сервера

Terminal Services Сервер может допустить "Stop 0x1E" или "Stop 0x50" ошибку в процессе печати клиента Terminal Services сервера. Это может быть вызвано использованием некоторых шрифтов в документе, который распечатывался, например:
+ Type 1 multiple master fonts (legacy fonts)
+ Far East fonts containing both English and a localized name
Проблема может появиться, если такой шрифт установлен на компьютере или добавлен, как шрифт принтера.

Решение:
Установите последний пакет исправлений Windows 2000.

Также можете попытаться решить проблему путём обновления драйверов для принтера.

Возникновение ошибки в Usbhub.sys Surprise Removal Plug-and-Play`я USB Hub`а

Когда вы часто отключаете Plug-and-Play Universal Serial Bus (USB) хаб (имеется ввиду спонтанное отключение без перезагрузки системы), то может появиться следующая ошибка :
STOP: 0x0000001E (0xC0000005, 0xF8CF75D0, 0x00000000, 0x00000044)
KMODE_EXCEPTION_NOT_HANDLED address 0xF8CF75D0 in USBHUB.sys
Ошибка возникает из-за USB драйвера.

Решение:
Для решения проблемы установите последний пакет исправлений. Впервые эта проблема была решена в Windows 2000 SP1.

BSOD: STOP 0x0000001e в Ntoskrnl.exe

Если во время загрузки вы получили такой стоп:
STOP 0x0000001e (0xc0000005, 0x801a8a83, 0x00000000, 0x005c0069)
KMODE_EXCEPTION_NOT_HANDLED
адрес 801a8a83 основывается на 80100000 - ntoskrnl.exe
Возможно, ваш SOFTWARE реестр повреждён.

Решение:
Восстановите реестр из резервной копии.


0x00000020: KERNEL_APC_PENDING_DURING_EXIT
Название ошибки указывает на disable count APC (счётчик отключений). Если счётчик показывает значение не равное нулю, то он и есть источник проблемы. Отрицательное значение указывает на то, что файловая система вызывала FsRtlEnterFileSystem большее количество раз, чем FsRtlExitFileSystem. Положительное значение указывает, наоборот, FsRtlExitFileSystem было вызвано большее количество раз, чем FsRtlEnterFileSystem.
Если у вас такая ситуация, проверьте все файловые системы установленные на машине. Сторонние перенаправители более всего подозреваются в сбое, так как они не были так тщательно протестированы, как NTFS, FAT, HPFS и RDR.
Текущий IRQL должен быть равен 0. Если нет, то определённый порядок аннулирования драйверов, возвращаясь на высоком уровне IRQ, может быть причиной возникновения ошибки.

Параметры:
1 - адрес APC, был в ожидании на момент выхода.
2 – disable count APC
3 - текущий IRQL уровень

Всегда пытайтесь заметить, что вы делали или какие приложения закрывали, какие драйвера были установлены на момент возникновения синего экрана. Этот симптом указывает на серьёзную проблему в драйверах третьей стороны.

Одной из известных причин этого стопа является Symantec AntiVirus 8.х и 9.0, установленный на серверах.

Решение:

Symantec AntiVirus 8.x

1. Перезагрузитесь в безопасном режиме.
2. Start -> Run -> CMD.EXE
3. Напечатайте следущее:
REG ADD HKLM\SYSTEM\CurrentControlSet\Services\Navap /V Start /T REG_DWORD /F /D 4
REG ADD HKLM\SYSTEM\CurrentControlSet\Services\Navapel /V Start /T REG_DWORD /F /D 4
3. Отключите сервер от сетки и перезагрузитесь.

Symantec AntiVirus 9.0

1. Перезагрузитесь в безопасном режиме.
2. Start -> Run -> CMD.EXE
3. Напечатайте следущее:
REG ADD HKLM\SYSTEM\CurrentControlSet\Services\Savrt /V Start /T REG_DWORD /F /D 4
REG ADD HKLM\SYSTEM\CurrentControlSet\Services\Savrtpel /V Start /T REG_DWORD /F /D 4


0x00000023: FAT_FILE_SYSTEM
Произошла ошибка во время записи или чтения с системного диска на фаловой системе FAT16 или FAT32. Возможна проблема с самим диском или с Interrupt Request Packet (IRP) пакетом.
Так же присиной может быть большая фрагментация диска, проблема в антивирусном програмном обеспечение или в ПО слежения за дисками (drive monitoring).

Решение:
Для решения этой проблемы следуйте следующим шагам, прока проблема не будет устранена.
1. Проверьте диск с помощмью утилит ChkDsk или ScanDisk.
2. Отключите сторонние фильтры файловой системы (такие как антивирусные сканнеры, брандмауэры, утилиты для архивирования данных)
3. Проверьте версию файла FASTFAT.SYS и убедитесь, что он соответствует действующей операционной системе.
4. Обновите оборудование, такое как жёсткие диски, CD-ROM и т.п.


0x00000024: NTFS_FILE_SYSTEM
Произошла ошибка во время записи или чтения с системного диска на фаловой системе NTFS. Возможна проблема с самим диском или с Interrupt Request Packet (IRP) пакетом.
Так же присиной может быть большая фрагментация диска, проблема в антивирусном програмном обеспечение или в ПО слежения за дисками (drive monitoring).

Решение:
Для решения этой проблемы следуйте следующим шагам, прока проблема не будет устранена.
1. Проверьте диск с помощмью утилит ChkDsk или ScanDisk.
2. Отключите сторонние фильтры файловой системы (такие как антивирусные сканнеры, брандмауэры, утилиты для архивирования данных)
3. Проверьте версию файла NTFS.SYS и убедитесь, что он соответствует действующей операционной системе и сервисному паку.
4. Обновите оборудование, такое как жёсткие диски, CD-ROM и т.п.


0x0000002A: INCONSISTENT_IRP
Состояния IRP (пакет ввода/вывода – I/O packet) не соответствовали друг другу.

Это когда поле или несколько полей IRP не соответствовали остальному состоянию IRP. Например, IRP, который был закончен, указывался, как всё ещё ждущий выполнения команд драйвера какого-либо устройства.

Параметры:
1 - адрес на котором IRP был найден в несоответствующем состоянии


0x0000002B: PANIC_STACK_SWITCH
Эта ошибка указывает на то, что область стека ядра переполнена. Это может возникнуть, когда драйвер, работающий на уровне ядра, использует слишком много места в области стека. Это так же может случиться, если серьёзная ошибка в самом ядре.

Параметры:
1. Область возникновения ошибки


0x0000002E: DATA_BUS_ERROR
Чаще всего данная ошибка указывает на неполадки памяти.

Параметры:
1 - адрес виртуальной памяти, который стал причиной ошибки
2 - физический адрес причины ошибки
3 - регистр статуса процессора (PSR)
4 - регистр инструкции ошибки (FIR)

Почти всегда причиной является оборудование системы – неверная конфигурация, несовместимое или повреждённое оборудование.
В большинстве случаев это неисправный RAM, Level 2 (L2) RAM cache ошибки, ошибки видео RAM и повреждённый жёсткий диск.
Так же это может случиться, когда драйвер обращается к 0x8XXXXXXX адресу памяти, который не существует.

Решения:
1. Если стоп случился на новоустановленой системе, то проверьте обновления для BIOS, SCSI и сетевой карты. Все обновления можно найти на сайте производителе оборудования.
2. Если синий экран случился после установления каких либо драйверов для оборудования, то драйвер, нужно удалить.
3. Если причиной является жёсткий диск, то следует запустить проверку диска на активном разделе или, если в систему не удаётся попасть из-за стопа, из консоли восстановления. Для этого запустите Chkdsk /f /r или Chkdsk /r из консоли.


0x00000035: NO_MORE_IRP_STACK_LOCATIONS
Драйвер высшего уровня пытался вызвать драйвер низшего уровня через IoCallDriver() интерфейс, но в запасе не было свободного места в области стека, поэтому драйвер низшего уровня не сможет достичь нужных параметров, так как для него вообще нет никаких параметров.
Это гибельная ситуация, так как драйвер высшего уровня считает, что заполнил параметры для драйвера низшего уровня (что-то он должен был сделать, чтобы вызвать драйвер низшего уровня). В то время как составитель аннулировал конец пакета, т.к. нет свободного места. Это означает, что, скорее всего, какая-то память была повреждена.

Параметры:
1. адрес IRP


0x00000036: DEVICE_REFERENCE_COUNT_NOT_ZERO
Драйвер устройства пытался удалить из системы одно из объектов его устройства, но счётчик обращений этого объекта не был равен 0.
Это означает, что для этого объекта были какие-то ещё невыполненные задачи (счётчик указывает номер причин, почему данный объект на может быть удалён).

Это ошибка вызова драйвера.

Параметры:
1. адрес объекта


0x0000003E: MULTIPROCESSOR_CONFIGURATION_NOT_SUPPORTED
Мультипроцессорная система не симметрична по отношению друг к другу.

Чтобы быть симметричными, процессоры должны быть одного типа и уровня. Например, попытка использовать процессор уровня Pentium и 80486 вызовет ошибку. Кроме того, на х86 системах, возможность вычислений дробей должны быть на обоих процессорах или ни на одном.


0x0000003F: NO_MORE_SYSTEM_PTES
Это случается, когда система выполнила слишком много операций ввода/вывода ( I/O ), что приводит к фрагментации виртуальной памяти.

В общем, ошибка говорит о нехватке РТЕ (page file entries), но на самом деле из-за фрагментации не возможно выделить драйверу целый кусок запрашиваемого количества памяти.

Часто видео драйвера пытаются получить большие каски виртуальной памяти. Так же программы резервирующие данные.

Так же причиной может являться драйвер, который плохо вычищает файл подкачки (swap).

Решения:

1. Увеличите объем виртуальной памяти.
2. Если отладчик ядра (kernel debugger) доступен проследите, где система запнулась и введите следующую команду:
!sysptes 3


0x00000040: TARGET_MDL_TOO_SMALL
Это ошибка драйвера.
Драйвер вызвал функцию IoBuildPartialMdl() и послал ей MDL, чтобы выявить часть источника MDL, но цель MDL не достаточно большая, чтобы отобразить пределы требуемых адресов. Источник и цель MDL, так же как длинна линии адресов определения, являются аргументами IoBuildPartialMdl() функции:

IoBuildPartialMdl(
IN PMDL SourceMdl,
IN OUT PMDL TargetMdl,
IN PVOID VirtualAddress,
IN ULONG Length
)


0x00000041: MUST_SUCCEED_POOL_EMPTY
Ошибка показывает, что какой-то драйвер запросил слишком много места в must_succeed pool.
В winNT и win2000 must_succeed pool очень мал, а в XP драйверам в обще не разрешено запрашивать там место для выполнения своих команд.

Параметры:
1 - величина запроса, который не может быть удовлетворён
2 - номер страниц, которые были использованы из nonpaged pool.
3 - номер запрашиваемых страниц из nonpaged pool.
4 - номер доступных страниц


0x00000044: MULTIPLE_IRP_COMPLETE_REQUESTS
Драйвер запросил завершение для IRP [IoCompleteRequest()], но пакет был уже завершён.
Эту ошибку сложно выявить.
Самый простой случай - драйвер пытается завершить одну и ту же операцию дважды, но этот случай бывает очень редко.
Так же бывает, что два различных драйвера пытаются завладеть пакетом и завершить его. Первый как правило срабатывает, а второй нет. Отследить, какой именно драйвер вызвал сбой, трудно, так как следы первого драйвера были переписаны вторым. Тем не менее, конфликт может быть выявлен, рассматривая DeviceObject поля, в каждом местоположении стэка.

Параметры:
1 - адрес IRP


0x00000048: CANCEL_STATE_IN_COMPLETED_IRP
Это ошибка указывает, что I/O Request Packet (IRP) был отменён сразу после того как был уже выполнен.
Это может быть вызвано драйвером, который сначала просит выполнить операцию, а потом отменить её выполнение.
Или это может быть вызвано несколькими драйверами, пытающимися неправильно завладеть одним и тем же IRP.

Параметры:
1 – указатель IRP


0x0000004C: FATAL_UNHANDLED_HARD_ERROR
Наиболее частые причины:
1. x218 - необходимая библиотека реестра не может быть загружена. Этот файл может отсутствовать или быть повреждённым. Чтобы решить проблему, вам понадобиться спасательная загрузочная дискета.
2. Драйвер может повредить ключ реестра во время загрузки в память, или память, в которую происходила загрузка этого ключа, не действительна. Особенно AST EISA машины с 16М и выше памятью должны иметь доступ к памяти выше 16М, т.е. в утилите конфигурации EISA этот параметр должен быть ENABLED (разрешён). Иначе файл, который загрузится в ту память, при чтении покажет - 0xffffffff.
3. x21A - или Winlogon или CSRSS (Windows) внезапно отказали в работе. Выходящий код может сказать больше. Обычно это - c0000005, что говорит о том, что неподдерживаемое исключение вызвало сбой в том или ином процессе. Здесь практически ничего нельзя сделать.
4. x221 - означает, что драйвер повреждён или системная библиотека была распознана, как повреждённая. NT делает всё, чтобы проверять целостность важных системных файлов. Синий экран показывает имя повреждённого файла. Если такое случилось, загрузитесь в любую другую систему или, если таковых нет, переустановите/отремонтируйте систему. Или убедитесь, что версия файла, который был повреждён, совпадает с версией файла в дистрибутиве NT и просто замените его с диска.
Постоянные ошибки с разными именами файлов означают проблемы с железом в I/O пути драйвера.


0x0000004D: NO_PAGES_AVAILABLE
Не хватает свободного места, чтобы продолжать операции.

Параметры:
1 - количество использованных страниц
2 - кол-во физических страниц на машине
3 - Extended commit value in pages
4 - Total commit value in pages

Причины:
1. Драйвер заблокировал в цикле редактируемые или отображаемые заполнители страницы. Это ошибка драйвера.
2. Драйвер накопителя не выполняет запросы. Это ошибка драйвера.
3. Не достаточно места в стэке накопителя для записи и/или редактирования страниц в. памяти. Это ошибка драйвера.
4. Все процессы были урезаны до минимума, все доступные страницы заполнены и места всё равно не хватает.
5. Драйвер забывает сбросить счётчик свободных страниц, после выполнения процессов.
6. Или цикличная операция не может быть завершена.

Решение:
Если отладчик (kernel debugger) доступен, печатайте следующие команды:
!process 0 7
!vm
dd mmpagingfiles
dd @$p

которые покажут какие драйвера, где и сколько ресурсов памяти занимают.


0x0000004E: PFN_LIST_CORRUPT
Причина - повреждённая/неисправная I/O структура драйвера.

Параметры:
1. значение 1
2. значение ListHead, которое повреждено
3. число доступных страниц
4. 0
1. значение 2
2. данные, которые удаляются
3. наивысшее число физических страниц
4. итог удаляемых данных

Windows 2000

Применяется к следующим системам:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Datacenter Server

How to Troubleshoot a "STOP 0x0000004E PFN_LIST_CORRUPT" Error Message

Симптомы:
STOP 0x0000004E PFN_LIST_CORRUPT (Parameter1, Parameter2, Parameter3, Parameter4
1 - значение 1
2 - ListHead повреждённое значение
3 - число доступных страниц
4 - 0
1 - значение 2
2 - значение в списке, которое удалялось
3 - самый высокий номер физических страниц
4 - reference count of entry being removed

Причина:
Ошибка возникает вследствие повреждения input/output структуры драйверов драйвером или любой другой проблемой.

Решение:
Сделайте диагностику системы (обычно, соответствующие программы предоставляются производителями оборудования).
Отключите все фильтр-драйвера файловой системы (file system filter drivers), такие, как бекапные утилиты (backup utilities), вирус-сканеры (virus scanners), или фаервол (firewall software).
Просмотрите Microsoft сайт, чтобы проверить совместимость оборудования и драйверов оборудования с Windows 2000:
http://www.microsoft.com/hcl/default.asp
Для информации о оборудовании вашего компьютера, свяжитесь с производителем.
Если эта ошибка появляется незакономерно или когда вы пытаетесь запустить какую-нибудь программу, удалите дополнительную память или протестируйте ваш random access memory (RAM). Эта ошибка также может проявляться, если у вас повреждённый RAM.


[0x00000050: PAGE_FAULT_IN_NONPAGED_AREA] общий обзор
Появляется, когда запрошенная информация не была найдена в памяти. Эта ошибка генерируется в случае, если адрес системной памяти, по которому система обратилась, чтобы получить какую-либо информацию, не существует.
Если это случилось на Terminal Server, проверьте драйвера третьей стороны для принтера.

Параметры:
1. указывает на адрес в памяти, который допустил ошибку
2. тип обращения ( 0x00000000 = операция чтения, 0x00000001 = операция записи )
3. если параметр не нулевой, то он показывает адрес инструкции, ссылающийся на адрес памяти в первом параметре.

Решения для систем:
  • Microsoft Windows NT
  • Microsoft Windows 2000 Professional
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home


[0x00000050: PAGE_FAULT_IN_NONPAGED_AREA] Windows NT

Windows NT:

Применяется к следующим системам:
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

Replacing TCP/IP After SP2 Causes STOP 0x00000050

Если на компьютере с Windows NT 4.0 был установлен Service Pack 2 (SP2) и вы пытаетеся удалить TCP/IP протокол, а потом снова добавить, то при загрузке компьютера вы можете получить следующие STOP ошибки:

STOP 0x00000050 (0xFF10c004, 0x0, 0x0, 0x0) PAGE_FAULT_IN_NONPAGED_AREA
или
STOP 0x00000050 (0xFF404004, 0x0, 0x0, 0x0) PAGE_FAULT_IN_NONPAGED_AREA
или
STOP 0x00000050 (0xA0133004, 0x0, 0x0, 0x0) PAGE_FAULT_IN_NONPAGED_AREA
Примечание: первый аргумент может меняться, но сам стоп (0x00000050) всегда одинаков.

Причина:
Это происходит из-за того, что в системе установлен сервис удалённого доступа (Remote Access Service) и он сконфигурирован использовать TCP/IP протокол либо на dial-in либо на dial-out протоколе.

Решение:
Чтобы избежать проблемы - после того, как вы добавили TCP/IP протокол опять, используйте следующие методы:
1. Установите SP2 после того, как вы добавили TCP/IP протокол, но перед перезагрузкой компьютера. Для этого нажмите "No", когда вам предложат перезагрузку после добавления TCP/IP.
или
2. После того, как вы добавили TCP/IP протокол, запретите TCP/IP в конфигурации RAS и перезагрузите Windows NT. После перезагрузки, установите SP2 и разрешите TCP/IP через RAS.

Чтобы решить проблему, используйте подходящий метод:

Method 1: Windows NT на FAT разделе
Загрузите компьютер с другой ОС (MS-DOS, Windows 95, Windows 3.x) и замените файл Tcpip.sys из \Winnt\System32\Drivers папки на файл из папки Service Pack 2.

Method 2: Windows NT на NTFS разделе

Установите параллельную установку Windows NT в новую директорию и замените файл Tcpip.sys из \Winnt\System32\Drivers папки на файл из папки Service Pack 2. Перезагрузитесь в начальный Windows NT и переустановите Service Pack 2. После удалите параллельную установку Windows NT.

Stop 0x00000050 во время перехода с Windows NT 4.0 на Windows 2000
Во время обновления с Windows NT 4.0 до Windows 2000, вы получаете следующий BSOD:
STOP 0x00000050 (любое значение, 0x00000001, любое значение, 0x00000000).
Одна из возможных причин этого BSOD, что на HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{Interface ID}\TcpAllowedPorts значение висит слишком много портов.

Решение:
1. Удалите ключ TcpAllowedPorts или как можно больше ключей из него.
2. После этого можете обновить систему.


0x00000050: PAGE_FAULT_IN_NONPAGED_AREA

[0x00000050: PAGE_FAULT_IN_NONPAGED_AREA] Windows 2000 Professional
Применяется к следующим системам:
  • Microsoft Windows 2000 Professional
Когда вы устанавливаете PC карточку на лаптоп с Windows 2000 Professional , ваша система вылетает в BSOD:
Stop: 0x00000050 (0xfffffff0 ,0x00000000, 0x8044d0da, 0x00000000) PAGE_FAULT_IN_NONPAGED_AREA.

Эта проблема может появляться, если у вас установлен Roxio Inc.`s Easy CD Creator Platinum 5.0 и Take Two backup ПО. Для решения необходимо обновить Roxio ПО:
http://www.roxio.com/en/support/roxio_support/ecdc/ecdc_software_updatesv5.jhtml.

STOP 0x00000050 in Sentinel.sys во время загрузки Windows 2000
Во время загрузки Windows 2000, вы получаете BSOD:
STOP: 0x00000050 (parameter1, parameter2, parameter3, parameter4) PAGE_FAULT_IN_NON_PAGED_AREA Sentinel.sys.

Причина:
Проблема возникает из-за повреждённой или несовместимой программы Rainbow Technologies `Sentinel`.
Решение:
1. Перезагрузите компьютер.
2. Нажмите F8 во время загрузки.
3. Выберите Safe Mode и нажмите Enter.
4. Если необходимо, выберите Windows 2000.
5. Обратитесь к http://www.rainbow.com/support/index.html, чтобы узнать, как удалить системный драйвер Sentinel.

STOP 0x00000050 в Sentinel.sys во время загрузки Windows 2000
Во время загрузки Windows 2000 получаете:
STOP: 0x00000050 (parameter1, parameter2, parameter3, parameter4) PAGE_FAULT_IN_NON_PAGED_AREA Sentinel.sys.
Эта проблема возникает из-за повреждённой или несовместимой версии программы Rainbow Technologies `Sentinel`.

Решение:
1. Перезагрузите компьютер.
2. Нажмите F8 во время загрузки.
3. Выберите Safe Mode и нажмите Enter.
4. Если необходимо, выберите Windows 2000.
5. Посетите http://www.rainbow.com/support/index.html чтобы узнать, как удалить системный драйвер Sentinel.


[0x00000050: PAGE_FAULT_IN_NONPAGED_AREA] Windows XP
Применяется к следующим системам:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Если:
1. Ваш компьютер автоматический перезагружается
2. После перезагрузки вы получаете следующие сообщение:

Microsoft Windows
The system has recovered from a serious error.
A log of this error has been created.
Please tell Microsoft about this problem.
We have created an error report that you can send to help us improve Microsoft Windows. We will treat this report as confidential and anonymous.
To see what data this error report contains, click here.

Чтобы посмотреть детали ошибки нажмите на "click here":
BCCode : 00000050 BCP1 : 0xffffffe0 BCP2 : 0x00000001 BCP3 : 0xf30da010 BCP4 : 0x00000000 OSVer : 5_1_2600 SP : 0_0 Product : 256_1
3. Вы получаете синий экран с сообщением:
A problem has been detected and Windows has been shut down to prevent damage to your computer
Technical information:
*** STOP: 0x00000050 (0xffffffe0, 0x0x00000001, 0xf30da010, 0x00000000)
PAGE_FAULT_IN_NONPAGED_AREA
4. При просмотре системных логов в Event Viewer, вы обнаруживаете ошибку:
Date: date
Source: System
Error Time: time
Category: (102)
Type: Error
Event ID: 1003
User: N/A
Computer: computer
Description: Error code 00000050, parameter1 0xffffffe0, parameter2 0x00000001, parameter3 0xf30da010, parameter4 0x00000000.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.Data: 0000: 53 79 73 74 65 6d 20 45 System E 0008: 72 72 6f 72 20 20 45 72 rror Er 0010: 72 6f 72 20 63 6f 64 65 ror code 0018: 20 30 30 30 30 30 30 35 00000MN 0020: 30 20 20 50 61 72 61 6d 0 Param 0028: 65 74 65 72 73 20 66 66 eters ff 0030: 66 66 66 66 64 31 2c
Примечание:
Симптомы ошибки могут изменяться в зависимости от её причин.
307973 HOW TO: Configure System Failure and Recovery Options in Windows
Четыре параметра в стоп-ошибке могут меняться в зависимости от конфигурации системы.
И не все стоп-ошибки возникают по причинам перечисленным ниже.

Причина:
Проблема появляется из-за некорректной работы драйвера USB Universal Reader от Lexar Media, он не совместим с ХР

Решение:
Обновите драйвера для USB


0x00000051: REGISTRY_ERROR
Ошибка указывает на повреждение системного реестра. Если отладчик (kernel debugger) доступен, отследите ошибку. Если он вам покажет, что вы в ветке системы (CmpWorker будет присутствовать в перечне), введите следующие команды:
dd CmpRegistryMutex+18 L1
!thread
Это выдаст вам ветку и место ошибки в реестре.

Эта ошибка так же может означать, что реестр допустил ошибку I/O, когда пытался прочитать один из его библиотек, отсюда следует, что ошибка могла быть вызвана проблемой с оборудованием или что сама система повреждена.
Такое может случиться, когда ресурсы на исходе, а система безопасность пытается обновиться. Если так, проверьте, является ли машина PDC или BDC. Так же сколько аккаунтов в базе данных SAM (Менеджер Безопасности Аккаунтов) и может ли это быть цель echo, и не заполнены ли соответствующие библиотеки почти до конца.

Параметры:
1. значение 1 (указывает, где появилась ошибка)
2. значение 2 (указывает, где появилась ошибка)
3. может указывать на библиотеку
4. может быть возвратным кодом HvCheckHive`а, если какая-либо библиотека повреждена


0x00000067: CONFIG_INITIALIZATION_FAILED
Это означает, что реестр не может создать место, необходимое для содержания его файлов. Это ошибка не должна никогда появляться, так как процесс создания такого места происходит на ранней стадии загрузки системы и поэтому места для создания бассейна должно быть достаточно.

Параметры:
1. 5
2. указывает на NTOSCONFIGCMSYSINI, который потерпел неудачу.


0x00000069: IO1_INITIALIZATION_FAILED
Инициализация I/O системы не удалась по каким-либо причинам. Больше, практически, никакой информации нет.
Такое могло случиться, если установка приняла не правильное решение по поводу инсталляции системы, или пользователь переконфигурировал систему. Или пытается установить образ одной системы на совершенно другую конфигурацию компьютера.


0x00000071: SESSION5_INITIALIZATION_FAILED
Эти коды кодов (SESSION1 - SESSION5) указывают место в NTOS\INIT\INIT.C, где была допущена ошибка.

Параметры:
1. указывает код статуса, который показал, что инициализация NT не прошла успешно.

Windows NT 2000 XP

Применяется к следующим системам:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows XP 64-Bit Edition
  • Microsoft Windows XP Professional

MS03-007: Unchecked Buffer in Windows Component May Cause Web Server Compromise

Относится стопу SESSION5_INITIALIZATION_FAILED

Microsoft впервые выпустил эту статью 17, 2003. В то время Microsoft был информирован о дыре в безопасности Windows 2000 Servers на IIS 5.0. Для атак использовался WebDAV, но корем уязвимости был Ntdll.dll.
Microsoft выпустил патч для Windows 2000 и продолжил работу над главной проблемой. Windows NT 4.0 так же имеет уязвимость в Ntdll.dll, но он не поддерживает WebDAV, поэтому эта уязвимость не может быть использована для атак Windows NT 4.0. Но патч для Windows NT 4.0 был выпущен всё равно.
К тому же Microsoft изучает уязвимости в Windows XP. Тем не менее, как и Windows NT 4.0, Windows XP не устанавливает Internet Information Services (IIS) по умолчанию. 28 мая 2003 Microsoft выпустил патч для Windows XP и Windows XP Service Pack 1.

Предупреждение:
Если вы используете Windows 2000 Service Pack 2 (SP2), вы должны проверить версию Ntoskrnl.exe до установки патча. Сделайте это так:
1. Откройте %Windir%\System32 folder.
2. Правой кнопкой мыши на Ntoskrnl.exe - Свойства (Properties) - Закладка Версия (Version tab).
Версии Ntoskrnl.exe с 5.0.2195.4797 до 5.0.2195.4928 несовместимы с этим патчем. Эти версии были разработаны только для Microsoft Product Support Services hotfixes. Если вы установите этот патч на компьютер с такими версиями Ntoskrnl.exe, копм зависнет и появиться "Stop 0x00000071" сообщение после перезагрузки. Если такое случиться, вам необходимо восстановить Windows, используя Windows 2000 Recovery Console и бекапную копию Ntdll.dll, которая находиться в папке Winnt\$NTUninstallQ815021$.
Чтобы обновить такой Ntoskrnl.exe вы должны связаться с Microsoft Product Support Services до установки патча. Номера телефонов и тарифы оплат вы найдёте на http://support.microsoft.com/default.aspx?scid=sz;en-us;top
Или вы можете установить Windows 2000 Service Pack 3 (SP3) до установки патча.

Симптомы:
Windows 2000 поддерживает World Wide Web Distributed Authoring and Versioning (WebDAV) протокол. WebDAV, как это описано в RFC 2518, это набор расширений для Hypertext Transfer Protocol (HTTP), который обеспечивает стандарты для правки и управление файлами между компьютерами в Internet. Просмотреть RFC 2518 можно по адресу:
ftp://ftp.rfc-editor.org/in-notes/rfc2518.txt
Эта уязвимость существует в Windows компонентах, которыми пользуется WebDAV. И появляется потому, что компоненты содержат непроверяемый буфер (unchecked buffer).
Взломщики могут воспользоваться уязвимостью, посылая специально сформированные HTTP запросы на компьютер с Microsoft Internet Information Services (IIS). Запрос может спровоцировать падение сервера или запустить коды взломщиков по их выбору. Код будет выполняться в контексте безопасности IIS сервиса. (По умолчанию, IIS запускается в LocalSystem контексте).
Microsoft рекомендует установить патч немедленно. Для дополнительной информации смотрите Microsoft Knowledge Base:
816930 MS03-007: How to Work Around the Vulnerability That Is Discussed in Microsoft Knowledge Base Article 815021

Смягчающие факторы
В конфигурации по умолчанию URLScan предупреждает об уязвимостях. URLScan - это часть IIS Lockdown. Для дополнительной информации об URLScan смотрите:
http://www.microsoft.com/technet/security/URLScan.aspp
Для дополнительной информации об IIS Lockdown tool смотрите:
http://www.microsoft.com/technet/security/tools/tools/locktool.asp
Данная уязвимость может использоваться только удалённо, через установленную связь по Web.

вверх

Решения:

Windows 2000

Для решения проблемы, установите последний пакет исправлений СП для Microsoft Windows 2000.

Информация по исправлению безопасности:

Windows XP

Следующие файлы можно скачать с Microsoft Download Center:
Windows XP (все языки)
Download the 815021 package now.
Windows XP 64-Bit Edition
Download the 815021 package now.
Дата Выпуска: May 28, 2003

Для дополнительной информации:

119591 How to Obtain Microsoft Support Files from Online Services
Microsoft проскандировал эти файлы на вирусы, используя самые обновлённые базы.
Предпосылки:
Этот патч должен быть установлен на Windows XP или Windows XP Service Pack 1 (SP1).
Для дополнительной информации:
322389 How to Obtain the Latest Windows XP Service Pack

Информация по установке:

Могут быть использованы следующие команды:
  1. /?: Показать все команды.
  2. /u: Использовать несопровождаемый способ.
  3. /f: Закрыть другие программы, когда компьютер выключается.
  4. /n: Не сохранять текущую конфигурацию (удаление патча впоследствии невозможно).
  5. /o: Переписывает OEM файлы без запросов.
  6. /z: Не перезагружать после того, как установка закончится.
  7. /q: Использовать "Тихий способ" (без вмешательства пользователя).
  8. /l: Вывести список установленных хотфиксов.
  9. /x: Распаковать файлы, не запуская установку.

Например, чтобы установить патч без вмешательства пользователя и не перезагружать компьютер после установки, используйте следующие команды:
q815021_wxp_sp2_x86_enu /u /q /z
Чтобы убедится, что установка патча прошла успешно, проверьте наличие ключа реестра:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP\SP2\Q815021

Информация по удалению:

Чтобы удалить патч воспользуйтесь Установкой/Удалением Программ (Add/Remove Programs tool) в Контрольной Панели (Control Panel).
Системный администратор может использовать Spunist.exe утилиту для удаления патча. Spuninst.exe находится в %Windir%\$NTUninstallQ815021$\Spuninst папке и поддерживает следующие команды:
  1. /?: Показать все команды.
  2. /u: Использовать несопровождаемый способ.
  3. /f: Закрыть другие программы, когда компьютер выключается.
  4. /z: Не перезагружать после того, как установка закончится.
  5. /q: Использовать "Тихий способ" (без вмешательства пользователя).

Требование по перезагрузке:

Необходимо перезагрузить компьютер после установки или удаления патча, так как он применяется к ядру системы, которое конфигурируется о время загрузки.

Файловая информация:

В английской версии этих фалов атрибуты должны быть, как указано в таблице или позже. Даты и время указаны в универсальном времени (UTC). Когда вы просматриваете файлы, даты будут представлены в локальном времени. Чтобы определить различие во времени, воспользуйтесь утилитами системы Дата и Время.
Windows XP
Дата Время Версия Размер Путь Имя файла
---------------------------------------------------------------------------------
02-May-2003 15:03 5.1.2600.114 651,264 %Windir%\System32\Ntdll.dll pre-SP1
01-May-2003 20:56 5.1.2600.1217 654,336 %Windir%\System32\Ntdll.dll with SP1
Windows XP 64-Bit Edition
Дата Время Версия Размер Путь Имя файла
------------------------------------------------------------------------------------
02-May-2003 15:03 5.1.2600.114 1,498,112 %WinDir%\System32\Ntdll.dll pre-SP1
01-May-2003 14:57 5.1.2600.114 654,336 %WinDir%\System32\Wntdll.dll pre-SP1
01-May-2003 20:56 5.1.2600.1217 1,508,864 %WinDir%\System32\Ntdll.dll with SP1
30-Apr-2003 21:43 5.1.2600.1217 657,408 %WinDir%\System32\Wntdll.dll with SP1
Вы так же можете посмотреть файлы, которые этот патч устанавливает, проверив ключ реестра:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP\SP2\Q815021\Filelist

вверх

Windows 2000

Информация по установке:

Следующие файлы доступны для скачивания с Microsoft Download Center:
Все языки, за исключением Japanese NEC
Download the 815021 package now.
Japanese NEC
Download the 815021 package now.
Дата выпуска: March 17, 2003

Для дополнительной информации:

119591 How to Obtain Microsoft Support Files from Online Services Microsoft проскандировал эти файлы на вирусы, используя самые обновлённые базы.

Предпосылки:

Патч должен быть установлен на Windows 2000 Service Pack 2 (SP2) или Windows 2000 Service Pack 3 (SP3). Для дополнительной информации смотрите Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
Примечание:
Если вы используете Windows 2000 Service Pack 2 (SP2), посмотрите предупреждение в начале этой статьи перед установкой патча.

Информация по установке:

Могут быть использованы следующие команды:
  1. /?: Показать все команды.
  2. /u: Использовать несопровождаемый способ.
  3. /f: Закрыть другие программы, когда компьютер выключается.
  4. /n: Не сохранять текущую конфигурацию (удаление патча впоследствии невозможно).
  5. /o: Переписывает OEM файлы без запросов.
  6. /z: Не перезагружать после того, как установка закончится.
  7. /q: Использовать "Тихий способ" (без вмешательства пользователя).
  8. /l: Вывести список установленных хотфиксов.
  9. /x: Распаковать файлы, не запуская установку.
Например, чтобы установить патч без вмешательства пользователя и не перезагружать компьютер после установки, используйте следующие команды:
q815021_w2k_sp4_x86_en /u /q /z
Чтобы убедится, что установка патча прошла успешно, проверьте наличие ключа реестра:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows 2000\SP4\Q815021

Информация по удалению:

Чтобы удалить патч воспользуйтесь Установкой/Удалением Программ (Add/Remove Programs tool) в Контрольной Панели (Control Panel) - "Windows 2000 Hotfix (SP4) Q815021.
"Системный администратор может использовать Spunist.exe утилиту для удаления патча. Spuninst.exe находится в %Windir%\$NTUninstallQ815021$\Spuninst папке и поддерживает следующие команды:

  1. /?: Показать все команды.
  2. /u: Использовать несопровождаемый способ.
  3. /f: Закрыть другие программы, когда компьютер выключается.
  4. /z: Не перезагружать после того, как установка закончится.
  5. /q: Использовать "Тихий способ" (без вмешательства пользователя).

Требование по перезагрузке:

Необходимо перезагрузить компьютер после установки или удаления патча, так как он применяется к ядру системы, которое конфигурируется на загрузке.

Файловая информация:

В английской версии этих фалов атрибуты должны быть, как указано в таблице или позже. Даты и время указаны в универсальном времени (UTC). Когда вы просматриваете файлы даты, будут представлены в локальном времени.
Чтобы определить различие во времени, воспользуйтесь утилитами системы Дата и Время.
Дата Время Версия Размер Путь Имя файла
-----------------------------------------------------------------------
15-Mar-2003 01:23 5.0.2195.6685 476,944 %Windir%\System32\Ntdll.dll
Вы так же можете посмотреть файлы, которые этот патч устанавливает, проверив ключ реестра:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows 2000\SP4\Q815021\Filelist

вверх

Windows NT 4.0 (All Versions)

Microsoft Internet Information Server (IIS) не предназначен для использования на Windows NT Server 4.0, Terminal Server Edition, и поэтому ими не поддерживается. Microsoft рекомендует пользователям использующим IIS 4.0 на Windows NT Server 4.0, Terminal Server Edition защитить свою систему, удалив IIS 4.0.

Информация по установке:

Следующие файлы доступны для скачивания с Microsoft Download Center:
Windows NT 4.0:
Все языки, исключая Japanese NEC и Chinese - Hong Kong:
Download the 815021 package now.
Japanese NEC:
Download the 815021 package now.
Chinese - Hong Kong:
Download the 815021 package now.
Windows NT Server 4.0, Terminal Server Edition:
Все языки:
Download the 815021 package now.
Дата выпуска: April 23, 2003

Для дополнительной информации:

119591 How to Obtain Microsoft Support Files from Online Services
Microsoft проскандировал эти файлы на вирусы, используя самые обновлённые базы.
Предпосылки:
Этот патч должен быть установлен на Windows NT 4.0 Service Pack 6a (SP6a) или Windows NT Server 4.0, Terminal Server Edition Service Pack 6 (SP6). Для дополнительной информации смотрите Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

Информация по установке:

Могут быть использованы следующие команды:
  1. /y : Удалить (только с /m или /q ).
  2. /f : Закрыть другие программы, когда компьютер выключается.
  3. /n : Не создавать папку Uninstall.
  4. /z : Не перезагружать после того, как установка закончится.
  5. /q : Использовать "Тихий" или несопровождаемый способ с вмешательством пользователя. (Это команда является расширенной командой - /m)
  6. /m : Использовать несопровождаемый способ с вмешательством пользователя.
  7. /l: Вывести список установленных хотфиксов.
  8. /x: Распаковать файлы, не запуская установку.
Например, чтобы установить патч c вмешательством пользователя и не перезагружать компьютер после установки, используйте следующие команды:
q815021i /q /z
Чтобы убедится, что установка патча прошла успешно, проверьте наличие ключа реестра:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Hotfix\Q815021

Информация по удалению:

Чтобы удалить патч воспользуйтесь Установкой/Удалением Программ (Add/Remove Programs tool) в Контрольной Панели (Control Panel).
Системный администратор может использовать Spunist.exe утилиту для удаления патча. Spuninst.exe находится в
%Windir%\$NTUninstallQ815021$\Spuninst папке и поддерживает следующие команды:
  1. /?: Показать все команды.
  2. /u: Использовать несопровождаемый способ.
  3. /f: Закрыть другие программы, когда компьютер выключается.
  4. /z: Не перезагружать после того, как установка закончится.
  5. /q: Использовать "Тихий способ" (без вмешательства пользователя).

Требование по перезагрузке:

Необходимо перезагрузить компьютер после установки или удаления патча, так как он применяется к ядру системы, которое конфигурируется на загрузке.

Файловая информация:

В английской версии этих фалов атрибуты должны быть, как указано в таблице или позже. Даты и время указаны в универсальном времени (UTC). Когда вы просматриваете файлы даты, будут представлены в локальном времени. Чтобы определить различие во времени, воспользуйтесь утилитами системы Дата и Время.
Дата Время Версия Размер Путь Имя файла
----------------------------------------------------------------------------------------
24-Mar-2003 10:38 4.0.1381.7212 367,376 %WinDir%\System32\Ntdll.dll Windows NT 4.0
24-Mar-2003 07:12 4.0.1381.33546 369,936 %WinDir%\System32\Ntdll.dll TSE

Дополнительная информация:

http://www.microsoft.com/technet/security/bulletin/MS03-007.asp

Если на вашем компьютере несколько процессоров (multiple processors), необходимо запустить Microsoft Baseline Security Analyzer (MBSA) с /nosum командой, чтобы запретить проверку checksum. Для дополнительной информации обратитесь к Microsoft Knowledge Base:
320454 Microsoft Baseline Security Analyzer (MBSA) Version 1.1 Is Available

вверх


0x00000073: CONFIG_LIST_FAILED

Информация применима к следующим системам:

• | Microsoft Windows 2000 Server
• | Microsoft Windows 2000 Advanced Server
• | Microsoft Windows 2000 Professional Edition
• | Microsoft Windows 2000 Datacenter Server
• | Microsoft Windows XP Professional
• | Microsoft Windows XP Home Edition

Причина
Это сообщение об ошибке указывает на то, что один или несколько разделов (SAM, SECURITY, SOFTWARE или DEFAULT) системного реестра не могут быть подключены при загрузке системы. Тем не менее ошибка не означает, что раздел реестра поврежден.

Решение

Для решения этой проблемы используйте четыре параметра включенные в сообщение об ошибке STOP: 0x00000073 для выяснения какой именно раздел не может быть загружен.

Четыре параметра указанные в сообщении об ошибке STOP: 0x00000073 могут быть разными в зависимости от того какой именно куст реестра не может быть подключен в момент возникновения ошибки.
(0x00000001, 0xc000017d, 0x00000002, 0xfc96fcc0)

В таблице указаны описания этих параметров:

Параметр | Описание
Первый параметр | 1
Второй параметр | Код состояния Windows указывает на то, что система обнаружила невозможность подключения куста.
Третий параметр | Индекс раздела реестра в списке разделов.
Четвертый параметр | Указатель UNICODE_STRING содержащий имя файла раздела реестра.

Используйте код состояния Windows из второго параметра (в данном случае 0xc000017d) для выяснения причины появления ошибки.

0xc000017d: STATUS_NO_LOG_SPACE это одна из наиболее частых причин возникновения данной ошибки. Этот параметр указывает на то, что у вас недостаточно свободного места на системном диске. Освободите место на системном диске для решения этой проблемы. Если это не поможет решить проблему выполните следующие рекомендации:

  1. Загрузите компьютер с использованием последней удачной конфигурации.
  2. Восстановите файлы реестра используя аварийный диск восстановления (ERD). За дополнительной информацией обратитесь к этой статье базы знаний Microsoft: Использование аварийного диска восстановления Windows NT . Примечание: эта возможность может быть применена только для восстановления разделов SOFTWARE и SYSTEM так как восстановление раздела SAM из ERD может уничтожить данные пользователя. Если у вас нет аварийного диска восстановления создайте его на компьютере под управлением Windows NT используя команду RDISK.
  3. Установите дополнительную копию Windows в другой раздел жесткого диска и восстановите файлы реестра исходной системы заменив их на файлы реестра новой системы. Файлы реестра находятся в каталоге %SYSTEMROOT%\System32\Config.
0xC000009A: STATUS_INSUFFICIENT_RESOURCES еще одна типичная причина возникновения ошибки. Этот параметр указывает на то, что недостаточно ресурсов для загрузки API, подразумевается, что вероятно Windows недостаточно памяти (оперативной памяти или файла подкачки). Реже этот параметр указывает на то, что ядро системы запущено вне части системной памяти, страницы которой в процессе страничного обмена могут быть переписаны на диск. За дополнительной информацией обратитесь к этой статье базы знаний Microsoft: Windows reports an "Out of Resources" error when memory is available .

Для получения информации о других кодах свяжитесь с Microsoft Product Support Services (PSS) или проверьте файл Ntstatus.h входящий в состав Core Software Development Kit (SDK). Для загрузки Core SDK посетите веб-узел Microsoft Platform SDK:
http://www.microsoft.com/msdownload/platformsdk/sdkupdate
Для получения информации о том как связаться с PSS посетите веб-узел Microsoft и перейдите по ссылке Contact Microsoft:
http://support.microsoft.com


0x00000074: BAD_SYSTEM_CONFIG_INFO
Эта ошибка может показывать то, что библиотека SYSTEM, загружаемая OSLOADER/NTLDR, повреждена. Тем не менее, это практически невозможно, так как OSLOADER всегда проверяет библиотеки после загрузки и убеждается, что они не повреждены.
Эта ошибка так же может означать, что некоторые требуемые ключи реестра и их параметры отсутствуют. Загрузка в LastKnownGood (Последней хорошей конфигурации) может решить проблему, или вам придётся переустанавливать систему, или воспользуйтесь Emergency Repair Disk.


0x00000075: CANNOT_WRITE_CONFIGURATION
Эта ошибка может появиться, если файлы SYSTEM библиотеки (SYSTEM и SYSTEM.ALT) не могут разместить дополнительную информацию, записанную в библиотеки реестра, между инициализациями реестра и первой фазы (когда файловые системы доступны). Эта ошибка обычно означает, что на диске недостаточно свободного места, так же это может произойти при попытке сохранить реестр на устройстве "только чтение".


0x00000076: PROCESS_HAS_LOCKED_PAGES
Эта ошибка может возникнуть по причине драйвера, который не полностью вычищен из памяти после I/O операции.
Параметры:

Параметры:
1. адрес процесса
2. число замкнутых страниц
3. число частных страниц
4. 0


0x00000077: KERNEL_STACK_INPAGE_ERROR
Запрошенная страница ядра не может быть прочитана. Причина ошибки может быть в плохом блоке файла виртуальной памяти или ошибки контролера диска (очень редко, причиной может быть нехватка ресурсов, а конкретней, резерв nonpaged pool (невиртуальной памяти) со статусом c0000009a [STATUS_INSUFFICIENT_RESOURCES]).Если первый и второй параметры кода ошибки равны 0, означает, что это не ошибка ядра. Значит, ошибка вызвана плохим оборудованием.
I/O статус c000009c (STATUS_DEVICE_DATA_ERROR) или C000016AL (STATUS_DISK_OPERATION_FAILED) обычно означает, что информация не может быть прочитана из-за плохого блока в памяти. После перезагрузки автоматическая проверка диска попытается определить адрес плохого блока.
Если статус будет C0000185 (STATUS_IO_DEVICE_ERROR) и виртуальная память находиться на SCSI диске, то должно быть проверено подключение и срок годности.

Параметры:
1. 0
2. 0
3. значение PTE на момент ошибки
4. адрес ошибки ядра
1. код статуса
2. I/O код статуса
3. номер страницы виртуальной памяти
4. Компенсация в страничный файл

Windows NT 2000

Решение STOP 0x00000077 и 0x0000007A сообщений..
Эти STOP сообщения относятся к ситуациям, когда Windows NT не может загрузить информацию о виртуальной памяти в рабочую память из-за проблем с оборудованием или программного обеспечения.
Возможные причины::
- Повреждённый блок на жёстком диске.
- Некорректное завершение оборудования SCSI.
- Плохое соединение жёсткого диска с контроллером.
- Ошибка контроллера жёсткого диска.
- Исчерпывание свободного места.
Значение второго восьмеричного параметра, может помочь вам выявить проблему:
Значения параметра:
0xC000009A STATUS_INSUFFICIENT_RESOURCES - недостаток свободного места.
0xC000009C STATUS_DEVICE_DATA_ERROR - плохой блок на диске.
0xC000009D STATUS_DEVICE_NOT_CONNECTED - плохое подсоединение, некорректное завершение работы или контроллер не иожет обнаружить диск.
0xC000016A STATUS_DISK_OPERATION_FAILED - плохой блок на диске.
0xC0000185 STATUS_IO_DEVICE_ERROR - некорректное завершение или плохое подсоединение оборудования SCSI.
В MSDN DDK файле NTSTATUS.H есть дополнительные коды статусов.

Применяется к следующим системам:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows NT Server 3.1
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Advanced Server

"Stop 0x00000077" or "KERNEL_STACK_INPAGE_ERROR"
Во время работы вы можете получить следующую ошибку:
Stop 0x00000077
KERNEL_STACK_INPAGE_ERROR

Причина:
Такое может произойти, когда запрошенная информации ядра не может быть прочитана из виртуальной памяти, или boot record заражён вирусом. Для выявления причины стопа вы должна тщательно изучить сообщение ошибки.
Если первый и третий параметры равны нулю, тогда четыре параметра выявляются как:
1. 0 (zero)
2. Page Table Entry (PTE) значение на момент ошибки
3. 0 (zero)
4. Адрес signature ядра
Если первый или третий параметры не равны нулю, тогда четыре параметра выявляются как:
1. Код статуса
2. I/O код статуса
3. Номер страницы виртуальной памяти
4. Offset into page file
В этом случае причина может быть выявлена через второй параметр (I/O код статуса), используя следующую информацию:
0xC000009A, или STATUS_INSUFFICIENT_RESOURCES: нехватка nonpaged pool ресурсов.
0xC000009C, или STATUS_DEVICE_DATA_ERROR: плохой кластер на жёстком диске.
0xC000009D, или STATUS_DEVICE_NOT_CONNECTED: неисправный кабель, зависание, или контроллер не смог получить доступ на жёсткий диск.
0xC000016A, или STATUS_DISK_OPERATION_FAILED: плохой кластер на жёстком диске.
0xC0000185, или STATUS_IO_DEVICE_ERROR: неправильное окончание процесса или неисправный кабель SCSI-основанного оборудования, или два устройства пытались использовать одно и то же IRQ.

Решение:
Используйте один из предложенных методов для решения этой проблемы:

Вирус загрузочного сектора:
Просканируйте жёсткий диск антивирусной программой.

Если это не вирус:
Просмотрите Журнал событий (Event Viewer) для получения дополнительной информации - какое оборудование стало причиной ошибки.

Плохой кластер на жёстком диске. Ошибка номера 0x77 зачастую является причиной плохого кластера в месте для виртуальной памяти, или ошибка контроллера диска, или в ОЧЕНЬ редких случаях, когда не хватает свободного места на диске.

Если первый и второй параметры равны нулю, то причиной является неисправное оборудование. Если I/O статус равен C0000185 и виртуальная память находиться на SCSI диске, вы должны проверить рабочее состояние кабелей и завершение SCS.

Если I/O код статуса 0xC000009C или 0xC000016A, это обычно указывает, что информация не может быть считана с жёсткого диска из-за плохого кластера.

Если возможно перезагрузите компьютер, Autochk автоматический запуститься и попытается выявить плохие кластеры. Если по какой либо причине Autochk не просканирует диск, запустите Autochk вручную. Если диск отформатирован на NTFS, запустите Chkdsk /f /r на системной партиции. Вы должны перезагрузить компьютер до того, как сканирование начнётся. Если вы не можете загрузить компьютер из-за этой ошибки, используйте Консоль (Command Console) и запустите Chkdsk /r .

Повреждённая память - random access memory (RAM), Level 2 (L2) SRAM cache, или RAM видео адаптера - ещё одна причина этой ошибки.
Проверьте, если все карты адаптеров хорошо закреплены в слотах и контакты нигде не отходят.

Отключите caching в BIOS и проверьте, решит ли это проблему.

Если это не решит проблему, то повреждена материнская плата.

Примечание:
Эта ошибка схожа с STOP: 0x0000007A


0x00000079: MISMATCHED_HAL
Уровень проверки HAL и тип конфигурации HAL не подходят ядру системы или типу машины. Такая ошибка, скорее всего, вызвана тем, что пользователь вручную обновил либо NTOSKRNL.EXE либо HAL.DLL. На машине мультипроцессорный HAL (MP) и унипроцессорное ядро (UP) или наоборот.

Параметры:
1. тип несовпадения (1, 2 или 3):
1. несовпадение уровней выпуска PRCB (несовпадение дат). Если дело в этом, то параметры 2 и 3:
2 - наибольший уровень у NTOSKRNL.EXE
3 - наибольший уровень у HAL.DLL
2. несовпадение версий, в этом случае параметры 2 и 3:
2 - версия NTOSKRNL.EXE
3 - версия HAL.DLL
версии:0 - 1 - 2 -
3. Micro Channel Architecture (MCA) компьютерам требуется специфический MCA HAL, в этом случае параметры 2 и 3:
2 - тип машины, определённый NTDETECT.COM
значение 2 означает, что этот HAL сделан для MCA
3 - тип машин, которые этот HAL поддерживает


0x0000007A: KERNEL_DATA_INPAGE_ERROR
Не может быть прочитана запрашиваемая ядром страница памяти.
Ошибка вызвана плохим блоком в памяти или ошибкой контроллера диска.

Параметры:
1. тип
2. статус ошибки (обычно I/O код статуса)
3. текущий процесс
4. адрес

Windows NT 2000 XP

Решение STOP 0x00000077 и 0x0000007A сообщений.
Эти STOP сообщения относятся к ситуациям, когда Windows NT не может загрузить информацию о виртуальной памяти в рабочую память из-за проблем с оборудованием или програмного обеспечения.

Возможные причины:
- Повреждённый блок на жёстком диске.
- Некорректное завершение оборудования SCSI.
- Плохое соединение жёсткого диска с контроллером.
- Ошибка контроллера жёсткого диска.
- Недостаток свободного места.

Применяется к следующим системам:
  • Windows XP
  • Windows 2000
  • Windows NT
Stop 0x0000007A or KERNEL_DATA_INPAGE_ERROR

Причина:
Stop 0x7A сообщение указывает, что страница памяти не была найдена и не может быть загружена в память. Это может быть из-за несовместимых дисков, контроллеров, firmware (BIOS) или оборудования.

Параметры:
1. Lock type value (0x00000001, 0x00000002, 0x00000003, or page table entry (PTE) address).
2. I/O код статуса
3. Если тип лока 0x00000001, этот параметр указывает на текущий процесс. Если тип лока 0x00000003, этот параметр указывает на адрес виртуальной памяти.
4. Адрес виртуальной памяти, который не может быть загружен в память.

Причина может быть выявлена через второй параметр (I/O код статуса), используя следующую информацию:
0xC000000E или STATUS_NO_SUCH_DEVICE: оборудование не может быть определено.
0xC000009A или STATUS_INSUFFICIENT_RESOURCES: нехватка nonpaged pool ресурсов.
0xC000009C или STATUS_DEVICE_DATA_ERROR: плохой кластер на жёстком диске.
0xC000009D или STATUS_DEVICE_NOT_CONNECTED: неисправный кабель, зависание, или контроллер не смог получить доступ на жёсткий диск.
0xC000016A или STATUS_DISK_OPERATION_FAILED: плохой кластер на жёстком диске.
0xC0000185 или STATUS_IO_DEVICE_ERROR: неправильное завершение процесса или неисправный кабель SCSI оборудования, или два устройства пытались использовать одно и то же IRQ.
Для большей информации о других возможных статусов, смотрите Ntstatus.h файл Windows XP Professional Driver Development Kit (DDK).
Решение:
Используйте один из предложенных методов для решения этой проблемы:

Просканируйте жёсткий диск антивирусной программой.

Просмотрите Журнал событий (Event Viewer) для получения дополнительной информации, какое оборудование стало причиной ошибки.

Такое может произойти, когда запрошенная страница информации ядра не может быть прочитана из виртуальной памяти, или master boot record заражён вирусом, или из-за несовместимых дисков, контроллеров, firmware (BIOS), оборудования.

Плохой кластер на жёстком диске. Ошибка номера 0x7А зачастую является причиной плохого кластера в месте виртуальной памяти, или ошибка контроллера диска, или в ОЧЕНЬ редких случаях, когда не хватает свободного места на диске.

Если первый и второй параметры равны нулю, то причиной является неисправное оборудование. Если I/O статус равен C0000185 и виртуальная память на SCSI жёстком диске, вы должны проверить рабочее состояние кабелей и завершение SCS.

I/O код статуса 0xC000009C или 0xC000016A обычно указывает, что информация не может быть считана с жёсткого диска из-за плохого кластера.
Если возможно, то перезагрузите компьютер, Autochk автоматический запуститься и попытается выявить плохие кластеры. Если по какой либо причине Autochk не просканирует диск, запустите Autochk вручную. Если диск отформатирован на NTFS, запустите Chkdsk /f /r на системной партиции. Вы должны перезагрузить компьютер до того, как сканирование начнётся. Если вы не можете загрузить компьютер из-за этой ошибки, используйте Консоль (Command Console) и запустите Chkdsk /r .

Повреждённая память - random access memory (RAM), Level 2 (L2) SRAM cache, или RAM видео адаптера - ещё одна возможная причина этой ошибки.
Проверьте, если все карты адаптеров хорошо закреплены в слотах. Что контакты нигде не отходят.

Отключите caching в BIOS и проверьте, решит ли это проблему.

Если вы недавно установили новое оборудование, отключите и отсоедините его.

Если это не решит проблему, то повреждена материнская плата.
Проверьте обновления на сайте поставщика вашего оборудования. Проверьте, чтобы ваш диск и его контроллер использовали одинаковые дополнительные установки. Если необходимо, установите медленней скорость передачи данных.

Так же вы можете установить драйвера для контроллеров, которых нет в библиотеках установочного диска Windows XP Professional. Для этого в начале установки нужно нажать F6, когда во время установки на экране появится:
Press F6 if you need to install a third party SCSI or RAID driver

Примечание:
Эта ошибка схожа с STOP: 0x00000077

Stop 0x0000007A во время установки на ATA66 компьютере

Во время установки Windows 2000 на IDE или UltraDMA66/ATA66 компьютер, вы получаете:
STOP 0x0000007A (0xc03f33fc, 0xc000000e, 0xfccffcba, ox0696b860)
KERNEL_DATA_INPAGE_ERROR ***Address xxxxxxxx has base at xxxxyyyy -
atapi.sys
Если у вас UlraDMA66/ATA66 (80 wire/40 pin) IDE кабель, подсоединенный к диску, на который вы устанавливаете Windows 2000, это может случиться, т.к. Windows 2000 не полностью поддерживает UltraDMA66 контроллер.

Решение:
Используйте подходящий способ, чтобы решить проблему:
1. Используйте стандартный ATA (40 wire/40 pin) IDE кабель и проверьте у производителя вашей мат. платы обновления драйверов ATA66 для Windows 2000.
2. Во время установки вас просят нажать F6, если Вам необходимо установить SCSI и RAID драйвера (if you need to install a third party SCSI or RAID driver), установите обновлённый драйвер Windows 2000 UltraDMA66.

Примечание: Некоторые старые мат.платы не поддерживают UltraDMA66/ATA66. Спросите вашего производителя ж.диска о установке джамперов или программе, которую вы могли бы использовать, чтобы включить поддержку протокола ATA33 на ATA66 протоколе на диске или мат.плате, которая имеет встроенный UltraDMA66/ATA66 контроллер, неподдерживаемый Windows 2000.


[0x0000007B: INACCESSIBLE_BOOT_DEVICE] общий оюзор

Ошибка 0x0000007B в Windows XP может возникать по ряду причин. Например при неполадках с оборудованием или с драйверами устройств; в случае использования одного прерывания (IRQ) несколькими устройствами; в случае повреждения загрузочного диска или файловой системы диска на котором установлена Windows и т.д.
В данном обзоре мы рассмотрим основные рекомендации по устранению данной ошибки в наиболее распространенных случаях ее возникновения.

Неполадки с драйверами устройств

Ошибка 0x0000007B может появиться во время установки Windows XP по следующим причинам:
• Драйвер устройства, необходимый контроллеру загрузки компьютера, не настроен или не установлен во время загрузки компьютера.
• Драйвер устройства, необходимый контроллеру загрузки, поврежден.
• Данные в реестре Windows XP (относящиеся к способу загрузки драйвера устройства при запуске) повреждены.
Windows XP требуется драйвер минипорта для связи с контроллером жесткого диска, используемым для запуска компьютера. Если Windows не может предоставить драйвер устройства контроллеру или Windows использует поврежденный или несовместимый драйвер, вам потребуется заменить этот драйвер на другой, совместимый с вашим контроллером и Windows XP.
Во время первой фазы установки Windows XP программа установки выводит следующее сообщение внизу экрана:
Нажмите клавишу F6, чтобы установить драйвер SCSI или RAID независимого разработчика.

Нажмите клавишу F6 и выполните инструкции, чтобы установить драйвер запоминающего устройства.

Для определения совместимости контроллера жесткого диска с Windows XP и получения данных о драйверах, находящихся на компакт диске Windows XP или доступных для загрузки, смотрите последнюю версию списка оборудования, совместимого с Windows XP:
"Последняя версия списка совместимого оборудования для Microsoft Windows XP"

В случае если поврежден раздел System в реестре и Windows XP не может загрузить драйвер минипорта, необходимый для работы контроллера загрузки необходимо восстановить резервную копию реестра.
За дополнительной информацией о восстановлении поврежденного системного реестра обратитесь к следующей статье:
"Восстановление поврежденного системного реестра, препятствующего запуску Windows XP"

Неполадки с оборудованием

Ошибка 0x0000007B может возникнуть в случае конфликта ресурсов между контроллером загрузки и другим контроллером или между устройствами SCSI. Также может возникать если преобразование диска не выполняется или параметры преобразования были изменены.
Для решения этих проблем выполните следующие действия.
1. Причиной появления сообщения об ошибке «Stop 0x0000007B» может являться конфликт между контроллером загрузки и одним из других устройств при использовании одного аппаратного прерывания (IRQ) или порта ввода-вывода. Если указанное сообщение об ошибке стало появляться после установки нового оборудования, удалите новое оборудование или перенастройте его таким образом, чтобы исключить конфликты с установленными контроллерами.
2. В случае если используется жесткий диск SCSI, проверьте цепь SCSI на правильность терминирования. Снимите неиспользуемые устройства SCSI и проверьте уникальность идентификаторов SCSI.
3. Убедитесь, что преобразование диска включено (если требуется) и его параметры не были изменены. Например, если недавно выполнялось изменение параметров контроллеров, это могло стать причиной неполадки.
Дополнительно по данному вопросу смотрите статью "0x0000007B: возникновение ошибки после переноса системного диска с установленой Windows XP на другой компьютер"

Неполадки в загрузочном разделе или файловой системе

Возможной причиной возникновения ошибки 0x0000007B может быть поврежденный загрузочный раздел.
Если файловая система повреждена и Windows XP не может подключить загрузочный раздел во время запуска можно перенести диск на другой компьютер под управлением Windows XP и выполнить для него команду chkdsk (проверка диска). Или параллельно установите новую копию Windows XP на этом диске (в другой папке). Программа установки Windows XP проверяет целостность раздела перед копированием файлов и может исправить некоторые ошибки в процессе установки.

Общие рекомендации

1. Если вы получили сообщение об ошибке во время установки Windows XP, обновите BIOS или установите драйверы Windows XP для контроллера жесткого диска.

2. Используйте при загрузке последнюю удачную конфигурацию. Это может помочь устранить неполадку, если вы недавно установили несовместимый драйвер для контроллера загрузки. Дополнительные сведения об использовании последней удачной конфигурации см. в следующей статье:
Как загрузить компьютер с Microsoft Windows XP, используя последнюю удачную конфигурацию

3. Используйте возможность восстановления в программе установки Windows XP. Дополнительные сведения о восстановлении Windows XP с помощью программы установки см. в следующей статье:
Как выполнить обновление (переустановку) Microsoft Windows XP

4. Восстановите резервную копию реестра. За дополнительной информацией о восстановлении поврежденного системного реестра обратитесь к следующей статье:
Восстановление поврежденного системного реестра, препятствующего запуску Windows XP

Описания решений проблемы:

Устранение неполадок связанных с появлением сообщения об ошибке «Stop 0x0000007B» или «0x4,0,0,0»

Отсутствие секции [SysprepMassStorage] приводит к появлению ошибки STOP 0x7B в Windows XP Sysprep Образах

Появление ошибки STOP 0x7B после переустановки или удаления Roxio Easy CD Creator 5 Platinum Edition

Появление сообщения об ошибке «Stop 0x0000007B» после переноса системного диска с Windows XP на другой компьютер

Появление сообщения об ошибке «STOP 0x0000007B» при загрузке после замены оборудования


[0x0000007B: INACCESSIBLE_BOOT_DEVICE] устранение неполадок

Устранение неполадок, связанных с появлением сообщения об ошибке «Stop 0x0000007B» или «0x4,0,0,0»

Информация в данной статье применима к:
• Microsoft Windows 2000 Server
• Microsoft Windows 2000 Professional
• Microsoft Windows NT Workstation 3.5
• Microsoft Windows NT Workstation 3.51
• Microsoft Windows NT Workstation 4.0 Developer Edition
• Microsoft Windows NT Server 3.5
• Microsoft Windows NT Server 3.51
• Microsoft Windows NT Server 4.0 Standard Edition
• Microsoft BackOffice Small Business Server 4.0
• Microsoft BackOffice Small Business Server 4.0a

Проблема
При запуске компьютера появляется одно из следующих сообщений об ошибке.
STOP: 0x0000007B Inaccessible Boot Device
Setup has encountered a fatal error that prevents it from continuing. Contact your software representative for help. The following status codes will assist them "0x4, 0, 0, 0"
Причина
Подобная ситуация может возникнуть в случае выполнения одного или нескольких из перечисленных ниже условий.
• Компьютер заражен вирусом загрузочного сектора.
• Драйвер устройства, необходимый контроллеру загрузки, не запускается при загрузке компьютера или поврежден, если в процессе установки с помощью команды WINNT /B запоминающие устройства обнаружены не были.
• В системе имеется конфликт ресурсов между контроллером загрузки и другим контроллером, или между устройствами SCSI.
• Преобразование диска не выполняется, или параметры преобразования были изменены.
• Загрузочный раздел поврежден и не может быть подключен Windows NT.
• Повреждены данные реестра Windows NT о драйверах устройств, которые запускаются в момент загрузки системы.
• Если ошибка возникает в процессе чтения второй установочной дискеты Windows NT, возможно, в BIOS компьютера включен параметр Drive Swapping.
• В некоторых случаях при установке операционной системы с помощью команды winnt /b возникают проблемы с определением контроллера диска. Контроллер не располагает достаточным количеством времени для отправки ответа с целью идентификации самого себя и, следовательно, определяется неправильно или не определяется вообще.
• При запуске программы установки с дисковода для компакт-дисков с интерфейсом SCSI сообщение об ошибке STOP 7B появляется, потому что в этом случае программа установки не разрешает добавить драйвер SCSI стороннего производителя.

Решение
Для решения проблемы воспользуйтесь одним из следующих способов.

Способ 1
Проверьте на наличие вирусов все дискеты, которые использовались в компьютере с момента последнего успешного запуска Windows NT.
Примечание. Возможно для определения и удаления разных вирусов придется воспользоваться несколькими антивирусными программами.
Если антивирусной программе не удается удалить вирус и восстановить зараженную систему, Windows NT необходимо переустановить.
Дополнительные сведения о защите загрузочного сектора Windows NT от вирусов см. в следующей статье базы знаний Майкрософт: Защита загрузочного сектора Windows от вирусов

Способ 2
Для взаимодействия с контроллером загрузки Windows NT необходим драйвер минипорта. Если на компьютере установлен поврежденный или несовместимый с контроллером драйвер, замените его, скопировав новый драйвер в папку %systemroot%\system32\drivers, или запустив процесс аварийного восстановления. Для успешного проведения загрузки компьютера с контроллером SCSI или включенным интерфейсом ATAPI дополнительно необходимо наличие драйверов устройств SCSIPORT.SYS и DISK.SYS (только Windows NT 4.0).
При установке с помощью команды WINNT /B сообщение об ошибке STOP 0x7B может появиться до того, как предпринимается попытка обнаружения запоминающих устройств. Чтобы избежать возникновения этой проблемы, при перезагрузке компьютера после исходного копирования файлов нажмите клавишу F6 как только появится сообщение «Setup is inspecting your computers hardware configuration». Это позволяет добавить запоминающее устройство в самом начале текстового режима установки.
Сообщение об ошибке «STOP 0x0000007B: Inaccessible Boot Device» после удаления дисковода для компакт-дисков

Способ 3
Если в системе существует конфликт прерываний IRQ или адресов портов ввода-вывода между контроллером загрузки и другим контроллером, Windows NT зависает или прерывает работу (появляется сообщение об ошибке Stop 0x0000007B). Если указанное сообщение об ошибке стало появляться после установки нового оборудования, удалите данное оборудование или перенастройте его таким образом, чтобы исключить конфликты с установленными контроллерами.
Проверьте правильность завершения цепочки SCSI. Удалите второстепенные устройства SCSI и убедитесь в отсутствии повторяющихся идентификаторов SCSI.

Способ 4
Загрузочный раздел Windows NT должен располагаться в пределах первых 1024 цилиндров загрузочного устройства (ограничение налагается вызовом INT-13 BIOS, который используется для запуска операционной системы). Убедитесь, что в параметрах CMOS включена поддержка адресации LBA на компьютерах на основе интерфейса IDE, а в параметрах BIOS для контроллеров SCSI — преобразование дисков, размер которых превышает 2 ГБ.

Способ 5
Если повреждена файловая система, и Windows NT в процессе запуска не удается подключить загрузочный том, перенесите диск на другой компьютер под управлением Windows NT и запустите для него команду CHKDSK. В качестве альтернативного решения попробуйте создать в отдельной папке на диске параллельную установку Windows NT. Перед выполнением копирования файлов Windows NT проверяет целостность тома и может исправить некоторые повреждения.

Способ 6
В результате некоторых повреждений в реестре Windows NT куста SYSTEM не запускается драйвер минипорта, который необходим контроллеру загрузки. Для решения этой проблемы воспользуйтесь одним из перечисленных ниже способов.
• Загрузите компьютер с помощью трех установочных дискет Windows NT и запустите программу восстановления. При появлении соответствующего запроса выберите проверку файлов реестра и замените только куст SYSTEM, содержащий сведения о драйверах устройств и службах, которые запускаются в процессе загрузки компьютера.
• Выполните параллельную установку Windows NT в отдельную папку, а затем с помощью редактора реестра исправьте поврежденные или отсутствующие данные в кусте SYSTEM.

Способ 7
Многие компьютеры оснащены дисководами 3,5 и 5,25 дюйма в одном блоке. При чтении второй установочной дискеты в процессе установки Windows NT на компьютере с таким дисководом может появиться сообщение об ошибке STOP 0x7B. Для устранения этой проблемы отключите в BIOS параметр Drive Swapping.
Дополнительные сведения об устранении этой проблемы см. в следующей статье базы знаний Майкрософт: Сообщение об ошибке «STOP: 0x0000007B Inaccessible_Boot_Device» в процессе обработки второго загрузочного диска

Способ 8
Выполните установку с трех загрузочных дискет, загрузочного компакт-диска, с помощью программы winnt или winnt32. В случае наличия установите драйвер устройства, рекомендованный производителем.

Способ 9
Выполните установку с трех загрузочных дискет. В случае наличия установите драйвер устройства, рекомендованный производителем.


[0x0000007B] после переноса системного диска с Windows XP на другой компьютер
Информация в данной статье применима к::
• Microsoft Windows XP Home Edition
• Microsoft Windows XP Professional Edition

Проблема
После переноса системного (загрузочного) диска Microsoft Windows XP на резервный компьютер при запуске Windows XP может появиться следующее сообщение об ошибке
STOP: 0x0000007B (0xF741B84C,0xC0000034,0x00000000,0x00000000)
INACCESSIBLE_BOOT_DEVICE

Причина
Данная ошибка возникает, если в Windows XP не установлены драйверы и разделы реестра для контроллеров устройств хранения данных, которыми оборудован резервный компьютер.
Контроллеры IDE выпускаются на основе различных наборов микросхем (например, производимых фирмами Intel, VIA и Promise). Каждый набор микросхем имеет собственный идентификатор PnP-ID (идентификатор Plug-n-Play).
Чтобы операционная система могла выполнить инициализацию дисков, идентификаторы PnP-ID контроллеров устройств хранения данных резервного компьютера должны быть внесены в реестр до загрузки Windows XP.

Решение
Для решения этой проблемы необходимо использовать на резервном компьютере то же самое оборудование.
• Если необходимо, замените оборудование резервного компьютера оборудованием того же самого производителя, того же типа и той же модели, которое использовалось на основном компьютере.
• Если системный диск представляет собой диск SCSI, используйте на резервном компьютере контроллер того же типа и той же модели, что и на основном компьютере.
• Если системный диск представляет собой диск IDE, используйте в новом компьютере системную плату такого же типа, как в старом (системная плата должна быть оснащена тем же самым набором микросхем IDE и иметь те же самые идентификаторы PnP-ID, что и системная плата на старом компьютере).
Если системный диск представляет собой диск SCSI, то, чтобы поместить соответствующие значения в реестр и установить драйверы, можно перед переносом содержимого системного диска установить контроллер SCSI, используемый на резервном компьютере. Windows XP обнаружит контроллер, установит драйверы и внесет изменения в реестр.
После того как данный контроллер SCSI отобразится в диспетчере устройств, его можно удалить. Если в дальнейшем системный диск будет перенесен на компьютер, использующий такой же контроллер SCSI, то Windows XP успешно загрузится, поскольку аналогичный контроллер уже использовался и в реестре присутствует необходимая информация.

Дополнительная информация
Существует возможность импортировать или присоединить требуемые элементы реестра и заранее скопировать драйверы для всех контроллеров IDE, поддержка которых встроена в Windows XP. Обратите внимание, что это позволит операционной системе работать с системным диском, но могут появиться проблемы, вызванные отличиями в другом оборудовании.
Данный способ обеспечивает поддержку контроллеров IDE, имеющих идентификаторы PnP-ID, перечисленные в приведенном ниже списке. Чтобы заранее определить контроллеры IDE, используемые основным и резервным компьютерами, можно просмотреть файл %SystemRoot%\Setupapi.log и найти идентификаторы PnP-ID, обнаруженные в процессе установки.
После определения идентификаторов PnP-ID, используемых на компьютере, можно добавить в реестр только эти идентификаторы.
Следующий список содержит идентификаторы PnP-ID контроллеров IDE, поддержка которых встроена в Windows XP.
   ;*********** Standard IDE ATA/ATAPI Controllers *********
   Secondary_IDE_Channel=%SystemRoot%\inf\Mshdc.inf

   ;*********** Generic ESDI Hard Disk_Controller **********
   *PNP0600=%SystemRoot%\inf\Mshdc.inf

   ;*********** Aztech IDE Controller **********************
   *AZT0502=%SystemRoot%\inf\Mshdc.inf

   ;*********** Device ID for Generic Dual PCI IDE *********
   PCI\CC_0101=%SystemRoot%\inf\Mshdc.inf

   ;************ALI IDE Controller ******************************
   PCI\VEN_10B9&DEV_5215=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_10B9&DEV_5219=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_10B9&DEV_5229=%SystemRoot%\inf\Mshdc.inf

   ;************Appian Technology **************************
   PCI\VEN_1097&DEV_0038=%SystemRoot%\inf\Mshdc.inf

   ;************CMD Technology *****************************
   PCI\VEN_1095&DEV_0640=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_1095&DEV_0646=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_1095&DEV_0646&REV_05=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_1095&DEV_0646&REV_07=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_1095&DEV_0648=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_1095&DEV_0649=%SystemRoot%\inf\Mshdc.inf

   ;************Compaq *************************************
   PCI\VEN_0E11&DEV_AE33=%SystemRoot%\inf\Mshdc.inf

   ;*************Intel *************************************
   PCI\VEN_8086&DEV_1222=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_8086&DEV_1230=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_8086&DEV_7010=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_8086&DEV_7111=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_8086&DEV_2411=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_8086&DEV_2421=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_8086&DEV_7199=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_8086&DEV_244A=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_8086&DEV_244B=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_8086&DEV_248A=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_8086&DEV_7199=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_8086&DEV_7601=%SystemRoot%\inf\Mshdc.inf

   ;*************PC Technology *****************************
   PCI\VEN_1042&DEV_1000=%systemroot%\inf\Mshdc.inf

   ;*************Silicon Integrated System *****************
   PCI\VEN_1039&DEV_0601=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_1039&DEV_5513=%SystemRoot%\inf\Mshdc.inf

   ;*************Symphony Labs *****************************
   PCI\VEN_10AD&DEV_0001=%SystemRoot%\inf\Mshdc.inf
   PCI\VEN_10AD&DEV_0150=%SystemRoot%\inf\Mshdc.inf

   ;*************Promise Technology ************************
   PCI\VEN_105A&DEV_4D33=%SystemRoot%\inf\mshdc.inf

   ;*************VIA Technologies, Inc. ********************
   PCI\VEN_1106&DEV_0571=%SystemRoot%\inf\Mshdc.inf

   ;*************Standard Microsystems Corp. ***************
   PCI\VEN_1055&DEV_9130=%SystemRoot%\inf\Mshdc.inf

   ;*************Toshiba ***********************************
   PCI\VEN_1179&DEV_0105=%SystemRoot%\inf\Mshdc.inf

Чтобы импортировать данную информацию, выполните следующие действия на двух различных испытательных компьютерах, на которых после обмена системными дисками появляется сообщение об ошибке «Stop 0x0000007B». После выполнения на каждом из этих компьютеров указанных действий, можно будет поменять между собой системные диски компьютеров и выполнить загрузку без появления ошибки «Stop 0x0000007B». Однако могут появиться другие проблемы, вызванные отличиями в другом оборудовании.

1. Скопируйте следующую информацию в программу «Блокнот» и сохраните полученный файл на дискете Имя файла Mergeide.reg, без расширения .txt.
********** Начало фрагмента **********
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\primary_ide_channel]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="atapi"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\secondary_ide_channel]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="atapi"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\*pnp0600]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="atapi"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\*azt0502]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="atapi"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\gendisk]
"ClassGUID"="{4D36E967-E325-11CE-BFC1-08002BE10318}"
"Service"="disk"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#cc_0101]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_0e11&dev_ae33]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1039&dev_0601]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1039&dev_5513]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1042&dev_1000]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_105a&dev_4d33]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1095&dev_0640]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1095&dev_0646]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1095&dev_0646&REV_05]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1095&dev_0646&REV_07]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1095&dev_0648]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1095&dev_0649]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1097&dev_0038]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_10ad&dev_0001]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_10ad&dev_0150]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_10b9&dev_5215]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_10b9&dev_5219]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_10b9&dev_5229]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="pciide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1106&dev_0571]
"Service"="pciide"
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_8086&dev_1222]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="intelide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_8086&dev_1230]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="intelide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_8086&dev_2411]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="intelide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_8086&dev_2421]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="intelide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_8086&dev_7010]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="intelide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_8086&dev_7111]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="intelide"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_8086&dev_7199]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="intelide"

;Добавление драйвера Atapi (необходимо наличие файла Atapi.sys в папке Drivers)

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi]
"ErrorControl"=dword:00000001
"Group"="SCSI miniport"
"Start"=dword:00000000
"Tag"=dword:00000019
"Type"=dword:00000001
"DisplayName"="Standard IDE/ESDI Hard Disk Controller"
"ImagePath"=hex(2):53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,44,00,\
  52,00,49,00,56,00,45,00,52,00,53,00,5c,00,61,00,74,00,61,00,70,00,69,00,2e,\
  00,73,00,79,00,73,00,00,00

;Добавление драйвера intelide (необходимо наличие файла intelide.sys в папке Drivers)

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IntelIde]
"ErrorControl"=dword:00000001
"Group"="System Bus Extender"
"Start"=dword:00000000
"Tag"=dword:00000004
"Type"=dword:00000001
"ImagePath"=hex(2):53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,44,00,\
  52,00,49,00,56,00,45,00,52,00,53,00,5c,00,69,00,6e,00,74,00,65,00,6c,00,69,\
  00,64,00,65,00,2e,00,73,00,79,00,73,00,00,00

;Добавление драйвера Pciide (необходимо наличие файлов Pciide.sys и Pciidex.sys в папке Drivers)

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PCIIde]
"ErrorControl"=dword:00000001
"Group"="System Bus Extender"
"Start"=dword:00000000
"Tag"=dword:00000003
"Type"=dword:00000001
"ImagePath"=hex(2):53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,44,00,\
  52,00,49,00,56,00,45,00,52,00,53,00,5c,00,70,00,63,00,69,00,69,00,64,00,65,\
  00,2e,00,73,00,79,00,73,00,00,00

********** Конец фрагмента **********

2. Извлеките файлы Atapi.sys, Intelide.sys, Pciide.sys и Pciidex.sys из архива %SystemRoot%\Driver Cache\I386\Driver.cab или скопируйте файлы в папку %SystemRoot%\System32\Drivers.
3. В проводнике Microsoft Windows щелкните правой кнопкой мыши файл Mergeide.reg, скопированный ранее на дискету, и выберите в появившемся меню пункт Слияние.
Подтвердите внесение изменений в реестр.
4. Завершите работу Windows XP, выключите компьютер, перенесите системный диск на другой испытательный компьютер, на котором ранее при загрузке появлялось сообщение об ошибке «Stop 0x0000007B» и проверьте, выполняется ли загрузка этого компьютера.


[0x0000007B] при загрузке после замены оборудования
Информация в данной статье применима к::
• Microsoft Windows XP Home Edition
• Microsoft Windows XP Professional Edition

Проблема
При запуске Microsoft Windows XP после замены системной платы может появиться следующее сообщение об ошибке:
STOP 0x0000007B INACCESSABLE_BOOT_DEVICE

Причина
Это происходит в тех случаях, когда набор микросхем контроллера IDE на новой системной плате отличается от набора микросхем контроллера IDE на старой системной плате.

Решение Для решения этой проблемы воспользуйтесь одним из следующих способов.

Способ 1. Обновление Windows XP
Если старый контроллер IDE и новый контроллер IDE определяют один и тот же размер жесткого диска, выполните обновление Windows XP.
Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
Как выполнить обновление (переустановку) Microsoft Windows XP
Если неполадки продолжают возникать, воспользуйтесь следующим способом.

Способ 2. Создание разделов и форматирование жесткого диска и переустановка Windows XP
Если новый контроллер IDE определяет другой размер жесткого диска, необходимо заново создать разделы и отформатировать жесткий диск, а затем переустановить Windows XP.
Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
Создание разделов и форматирование жесткого диска в Windows XP


[0x0000007B] при установке Windows XP из образа Sysprep
Отсутствие секции [SysprepMassStorage] приводит к появлению ошибки STOP 0x7B в Windows XP Sysprep Образах

Информация в данной статье применима к::
• Microsoft Windows XP Home Edition
• Microsoft Windows XP Professional Edition

Проблема
При запуске программы установки Windows XP после копирования образа на новый компьютер, вы можете получить следующее сообщение об ошибке:

STOP 0x0000007B
INACCESSABLE_BOOT_DEVICE

Причина
Эта проблема может проявляться в случае если в файле Sysprep.inf (файл ответов Sysprep) который используется ведущим компьютером (до того как был создан образ) отсутствовала секция [SysprepMassStorage]

Решение
Когда вы используете секцию [Sysprep] с параметром "BuildMassStorageSection=yes" в файле Sysprep.inf, вы должны убедиться в том, что секция [SysprepMassStorage] соответствует секции [Sysprep].
Например:
[Sysprep] BuildMassStorageSection=yes
[SysprepMassStorage]
Секция [Sysprep] автоматически производит вход в секцию [SysprepMassStorage] и выход из нее, если не удается загрузить требуемый загрузочный диск и генерируется сообщение об ошибке 0x7B

Дополнительная информация
Для получения дополнительной информации смотрите файлы Support\Deploy.cab\Deploy.chm и Ref.chm которые расположены на Windows XP Professional CD-ROM.


[0x0000007B: INACCESSIBLE_BOOT_DEVICE] общий оюзор

[0x0000007B] после переустановки или удаления Roxio Easy CD Creator 5
Появление ошибки STOP 0x7B после переустановки или удаления Roxio Easy CD Creator 5 Platinum Edition

Информация в данной статье применима к:
• Microsoft Windows XP Home Edition
• Microsoft Windows XP Professional Edition

Проблема
Во время перезагрузки компьютера после переустановки или удаления Roxio Easy CD Creator 5 Platinum Edition вы можете получить следующее сообщение об ошибке:

A problem has been detected and Windows has been shut down to prevent damage to your computer.

If this is the first time you've seen this Stop error screen, restart your computer. If this screen appears again, follow these steps:

Check for viruses on your computer. Remove any newly installed hard drives or hard drive controllers. Check your hard drive to make sure it is properly configured and terminated. Run CHKDSK /F to check for hard drive corruption, and then restart your computer.

Technical information:
*** STOP: 0x0000007B (0xF9E62640, 0xC0000034, 0x00000000, 0x00000000)
Причина
Данная проблема может возникать в случае если запись в системном реестре о драйвере Prtseqrd.sys не была удалена во время удаления Easy CD Creator 5 Platinum Edition. Данная запись в системном реестре добавляется программой установки Easy CD Creator 5 Platinum Edition.
После удаления программы файл драйвера Prtseqrd.sys также удаляется, но в некоторых случаях значение реестра остается и приводит к появлению ошибки в момент загрузки компьютера.

Решение
Способ 1 Изменение значений системного реестра с использованием консоли восстановления
1. Загрузите копьютер с диска Windows XP CD-ROM, нажмите R для загрузки консоли восстановления, войдите используя пароль администратора.
2. Напишите следующие команды и нажмите ENTER после каждой команды:
cd\windows\system32\config
ren system system.old
ren software software.old
ren SAM SAM.old
ren security security.old
ren default default.old
copy drive on which Windows is installed:\windows\repair\system
copy drive on which Windows is installed:\windows\repair\software
copy drive on which Windows is installed:\windows\repair\SAM
copy drive on which Windows is installed:\windows\repair\security
copy drive on which Windows is installed:\windows\repair\default
Вы получите сообщение "1 file(s) copied" после каждой команды копирования.
3. Напишите exit, нажмите ENTER, и перезагрузите компьютер.
4. Войдите в систему с учетной записью администратора.
Примечание: разрешение экрана может быть установлено на очень низкий уровень.
5. Нажмите Пуск, затем Выполнить, напишите regedit, и нажмите OK.
6. Перейдите к разделу HKEY_LOCAL_MACHINE, нажмите Загрузить куст из меню Файл.
7. Откройте папку C:\Windows\System32\Config, нажмите на файле System.old, нажмите Открыть.
8. В имени раздела напишите test и нажмите OK.
Оригинальный куст System будет загружен ниже исходного HKEY_LOCAL_MACHINE как "test".
9. Перейдите к следующей ветке реестра:
HKEY_LOCAL_MACHINE\test\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
10. В правой панели редактора реестра выберите параметр LowerFilters и нажмите Удалить в меню Правка.
11. В правой панели редактора реестра выберите параметр UpperFilters и нажмите Удалить в меню Правка.
12. Перейдите к следующей ветке реестра:
HKEY_LOCAL_MACHINE\test\ControlSet001\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}
13. В правой панели редактора реестра зайдите в свойства параметра UpperFilters.
14. В поле Значение удалите запись PrtSeqRd и нажмите OK.
15. Перейдите к следующей ветке реестра:
HKEY_LOCAL_MACHINE\test\ControlSet001\Services
16. Отключите службы соответствующие следующим подразделам путем изменения значения параметра Start на 4:
Cdr4_xp
Cdralw2k
cdudf_xp
dvd_2K
mmc_2K
PrtSeqRd
pwd_2K
UdfReadr_xp
17. Проделайте шаги с 10 по 17 для всех разделов ControlSet00x, таких как ControlSet002 в ветке HKEY_LOCAL_MACHINE\test\.
18. Выгрузите куст System.old.
19. Закройте редактор реестра и перезагрузите куст реестра System:
a. Загрузите копьютер с диска Windows XP CD-ROM, нажмите R для установки Windows в режиме восстановления, войдите используя пароль администратора.
b. Перейдите в папку Windows\System32\Config. Для этого напишите команду chdir system32\config находясь в C:\Windows и нажмите ENTER.
c. Напишите ren system system.xxx и нажмите ENTER.
d. Напишите ren system.old system и нажмите ENTER.
e. Напишите exit и нажмите ENTER для выхода из консоли восстановления и перезагрузите компьютер.
Способ 2: Изменение куста реестра system из другой копии Windows установленной на том же компьютере.
1. Запустите редактор реестра из рабочей копии Windows и перейдите к разделу HKEY_LOCAL_MACHINE.
2. В меню Файл выберите Загрузить куст.
3. Откройте папку %SystemRoot%\System32\Config системы в реестр которой необходимо внести изменения, выберите файл System и нажмите Открыть.
4. В окне загрузки куста напишите test. Куст System будет загружен в качестве подраздела текущего раздела HKEY_LOCAL_MACHINE как "test".
5. Проделайте шаги с 10 по 17 из Способа 1.
6. Выгрузите куст test.
7. Закройте редактор реестра и перезагрузите компьютер в ту систему в которую вносились изменения.

Дополнительная информация
За дополнительной информацией об использовании консоли восстановления обратитесь к этим статьям базы знаний Майкрософт:
Установка и использование консоли восстановления в Windows XP

Описание консоли восстановления Windows XP

Как восстановить работу системы после повреждения системного реестра, препятствующего запуску Windows XP

How To Replace a Driver by Using Recovery Console in Windows 2000


0x0000007D: INSTALL_MORE_MEMORY
Недостаточно оперативной памяти, чтобы загрузить Windows NT (необходимо 5 MB).

Параметры:
1. номер найденных физических страниц
2. нижняя физическая страница
3. высшая физическая страница
4. 0


0x0000007E
Информация применима к следующим системам:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

"STOP 0x0000007E" Error Message After You Upgrade to Windows XP

После обновления до Windows XP, вы можете получить следующий стоп:
STOP: 0x0000007E (0xC0000005, 0x804E518E, 0xFC938104, 0xFC937E04)
SYSTEM_THREAD_EXCEPTION_NOT_HANDLED
Примечание: четыре параметра в этом сообщении могут меняться, в зависимости от конфигурации системы.

Причина:
Это может случиться, когда системная генерирует исключение, которое поддержка ошибок (error handler) не может уловить.
Это может случиться, когда одно из следующих высказываний верно:
  1. Не хватает дискового пространства. Если ошибка появилась после первой перезагрузки во время установки Windows или сразу после того, как установка завершилась, на жёстком диске может быть не достаточно места, чтобы запустить Windows.
  2. Несовместимость BIOS. Если ошибка появилась после первого рестарта во время установки Windows или сразу после того, как установка завершилась, BIOS может быть несовместим с Windows.
    Несовместимые драйвера видео адаптера.
  3. Повреждённый Random Access Memory (RAM).
  4. Повреждённый драйвер оборудования или системный сервис.
  5. Несовместимая программа третьей стороны удалённого управления. Если ошибка ассоциируется с Win32k.sys файлом, это может быть из-за программы третьей стороны удалённого управления компьютером.
Решение:
Используйте один из предложенных методов для решения этой проблемы:

Метод 1:
Убедитесь, что на диске достаточно свободного мета. Удалите ненужные файла с жёсткого: временные файлы (temporary files), временные интернет файлы (Internet cache files), бэкапы от программ, .chk файлы, которые содержут фрагменты файлов от сканирования диска. Так же вы можете воспользоваться другим HDD с большей ёмкостью.

Метод 2:
Обновите BIOS. Свяжитесь с производителем материнской платы и выясните обновления для BIOS. Вы можете временно отключить такие функции в BIOS, как caching или shadowing.
65416 Hardware and Software Third-Party Vendor Contact List, A-K
60781 Hardware and Software Third-Party Vendor Contact List, L-P
60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

Метод 3:
Посмотрите Microsoft Hardware Compatibility List (HCL) список, чтобы выяснить, является ли ваше PCI оборудование совместимым с Windows XP.
314062 The Latest Windows XP Hardware Compatibility List
Обновите последние драйвера видео адаптера. Если драйвер указан на стоп-экране, отключите или удалите этот драйвер.
Отключите или удалите все драйвера или сервисы, которые вы добавили последними. Если ошибка появляется во время загрузки Windows и партиция, на которой стоит система, использует NTFS, возможно использование Безопасного режима (Safe mode), чтобы переименовать или удалить неисправный драйвер. Если драйвер используется, как часть системы во время загрузки, то необходимо загрузиться в Recovery Console, чтобы получить доступ к файлу.
Если проблема ассоциируется с Win32k.sys файлом, причина проблемы может быть в программе удалённого доступа третьей стороны. Если такая программа установлена, вы можете удалить сервис загрузившись в Recovery Console и удалить специфический файл системного сервиса.

Метод 4:
Если у вас есть возможность загрузиться в Безопасном режиме (Safe mode), удалите все драйвера, которые не имеют digital signeture. Для дополнительной информации, как это сделать, обратитесь к статье:
316434 HOW TO: Perform Advanced Clean-Boot Troubleshooting in Windows XP

Метод 5:
В редких случаях вы можете выявить неисправный драйвер третьей стороны. Вы можете попытаться решить эту проблему, переместив все драйвера третьей стороны из WindowsSystem32Drivers в другую директорию. Чтобы это осуществить, загрузитесь в Recovery Console или в другую установку Windows, если таковая имеется. Только убедитесь, что папка, в которую вы перемещаете эти файлы, не была создана - 8/13/2001. Если компьютер под управлением драйвера контроллера IDE или SCSI третьей стороны, необходимо установить эти драйвера и оставить их в WindowsSystem32Drivers. Перезагрузите компьютер и продолжайте установку. Для дополнительной информации, как отключить сервис, который предотвращает загрузку Windows, обратитесь к следующей статье:
310602 How to Disable a Service or Device that Prevents Windows from Starting

Дополнительная информация
Если вы получили стоп 0x0000007E, когда вы первый раз загружаете компьютер после установки и вы не устанавливали никаких драйверов 3-ей стороны во время установки Windows, то проблема может быть в оборудовании неподдерживаемом Windows XP. И это как раз и происходит от того, что ХР всё равно пытается установить свои драйвера.
Если вы получили этот стоп после апгрейда с Windows 2000 или вы только, что подключили новое оборудование, проблемой может быть несовместимый драйвер или само оборудование. Для дополнительной информации:
315222 A Description of the Safe Boot Mode Options in Windows XP
314058 Description of the Windows XP Recovery Console
308041 Resources for Troubleshooting Startup Problems in Windows XP

Так же для дополнительной информации вы можете обратиться к статье 0x0000000A


[0x0000007F: UNEXPECTED_KERNEL_MODE_TRAP] общий обзор
Эта ошибка означает, что произошло непредвиденное прерывание в режиме ядра, или вид прерывания, которое ядро не разрешает (захват(a bound trap) или вид прерывания, которое влечёт за собой немедленную смерть (двойная ошибка(double fault)). Первое число в интервалах кода ошибки - число прерывания (8 = double fault). Чтобы узнать больше, что это за прерывание, обратитесь к мануалу Intel x86 семьи. Пользуясь отладчиком ядра (kernel debugger), KB и !TRAP можно выяснить откуда прерывание происходит. В общем, ошибка появляется, когда процессор допускает ошибку, с которой ядро не может справиться. Чаще всего возникает из-за неисправного модуля памяти, также из-за разгона процессора. Попробуйте отменить в BIOS - sync negotiation (синхронная передача данных).

0x0000007F: UNEXPECTED_KERNEL_MODE_TRAP (общий обзор)

Эта ошибка означает, что произошло непредвиденное прерывание в режиме ядра, или вид прерывания, которое ядро не разрешает (захват(a bound trap)), или вид прерывания, которое влечёт за собой немедленную смерть (двойная ошибка(double fault)). Первое число в интервалах кода бага - число прерывания (8 = double fault). Чтобы узнать больше, что это за прерывание, обратитесь к мануалу Intel x86 семьи.
Пользуясь отладчиком ядра (kernel debugger), KB и !TRAP можно выяснить от куда прерывание происходит.
В общем, баг появляется, когда процессор допускает ошибку, с которой ядро не может справиться. Чаще всего возникает из-за плохого RAM, так же из-за разгона процессора.
Попробуйте отменить в BIOS - sync negotiation (синхронная передача данных).

Применяется в системам:
  • Windows XP Professionall

Stop 0x0000007F or UNEXPECTED_KERNEL_MODE_TRAP

 Причина:
Stop 0x7F сообщение указывает на то, что одна из 3-ёх проблем появилась в режиме ядра (kernel-mode):

  1. Ситуация, которую ядро не допускает, или прерывание (так же называется - bound trap).
  2. Проблема программного обеспечения.
  3. Ошибки устройств.
Параметры:
1. Исключительный код процессора.
2. Это значение 0x00000000 (ноль).
3. Это значение 0x00000000 (ноль).
4. Это значение 0x00000000 (ноль).
Первый параметр самый важный и он может принять насколько различных значений, указывающих на разные причины этой ошибки. Вы можете найти условия возникновения Stop 0x7F на всех x86 микропроцессорах в их мануале, т.к они специфичны для x86 платформ. Вот несколько часто встречающихся:
  1. 0x00000000, или ошибка деления на 0, возникает когда "делить" (DIV) инструкция делит на 0. Битая память, другие проблемы с оборудованием или проблемы с ПО могут привести к этой ошибке.
  2. 0x00000004, или Переполнение, в результате предыдущих операций был взведён флаг переполнения ((OF), а процессор обращается к модулю прерывания.
  3. 0x00000005, or Bounds Check Fault, указывет, что процессор, во время выполнения операции BOUND, обнаружил, что операнд (оп.код операции) превысил указанный лимит. Инструкция BOUND используется, чтобы проверять, что числа массива находятся в определённом промежутке.
  4. 0x00000006, or Invalid Opcode, возникает, когда процессор пытается выполнить недопустимую операцию. Обычно такое случается, когда указатель инструкций (instruction pointer) неисправен из-за повреждённой памяти и указывает на неверную позицию.
  5. 0x00000008, или Двойная Ошибка (Double Fault), указывает на двойное исключение во время попытки вызвать модуль (the handler). Обычно, два исключения могут быть выдержанны в очереди, но есть несколько исключений (почти всегда вызванных проблемами с устройствами), из-за которых процессор вызывает двойную ошибку.
Реже встречающиеся ошибки:
  1. 0x00000001: A system-debugger call.
  2. 0x00000003: A debugger breakpoint.
  3. 0x0000000A: A corrupted Task State Segment.
  4. 0x0000000B: An access to a memory segment that was not present.
  5. 0x0000000C: An access to memory beyond the limits of a stack.
  6. 0x0000000D: An exception not covered by some other exception; a protection fault that pertains to access violations for applications.

Решение:
Следующие решения специфичны к Stop 0x7F ошибкам. для дополнительной информации обратитесь к статье M$ "Stop Message Checklist".

1. Stop 0x7F ошибки обычно возникают из-за испорченной, плохо работающей памяти (RAM). Если вы только что подключили новое устройство - отключите его и посмотрите, если это решит проблему. Запустите диагностическое ПО, которое пришло к вам от производителя системы, чтобы выявить если какой-нибудь компонент не рабочий/плохо работает.

2. Разгон процессора (overclocking) может стать причиной Stop 0x7F или другие ошибки из-за перегрева. Когда диагностируете разогнанную систему, сначала снимите все разгоны до тех, которые рекомендованы производителем.

3. Проблема может быть из-за поцарапанных, испорченных компонентов на материнской плате. В этом случае вам необходимо отнести мат. плату на диагностику.

4. Stop 0x7F сообщение может появиться после установки несовместимого ПО, драйверов или системных сервисов. Свяжитесь с производителем ПО и выясните о каких-либо дополнительных обновлений для Windows XP Professional. Использование совместимых программ особенно важно в случае с Бэкапными программами (backup programs), мультимедийным ПО, антивирусными и CD-записывающими программами.

5. Для дополнительной информации обратитесь к статье http://www.microsoft.com/windows/reskits/webresources. Используйте в поиске ключевые слова winnt, 0x0000007F и 0x7F.

Перечень решений:

0x0000007F: возникновение ошибки во время установки Windows XP

0x0000007F: возникновение ошибки при Symantec AntiVirus

0x0000007F: возникновение ошибки при добавлении модуля памяти с использованием функции Hot Add Memory на компьютере с Windows Server 2003 (SP1)

Однобитная ошибка в ESP регистре процессора вызывает STOP 0x0000007F (0x00000008,...)


[0x0000007F] в процессе установки Windows XP
Во время установки Windows XP вы можете столкнуться со следующими симптомами:
- Сообщение об ошибке "STOP 0x0000007f".
- После отображения страницы приветствия компьютер выключается или перезагружается.

Проблема может возникать из-за несовместимости версии микропрограммы или настройки BIOS несовместимы с устанавливаемой операционной системой.

Для решения проблемы последовательно выполните следующие действия:

1. Сбросте настройки BIOS в положение по умолчанию (default)

Если проблема не исчезла, то переходите к пункту 2.

2. Обновите версию прошивки BIOS.

3. В процессе установки в момент когда программа установки Windows показывает предложение нажать F6 для установки дополнительных драйверов, нажмите F7 для выбора ядра HAL для установки. Это предотвратит использование вашим компьютером Advanced Configuration and Power Interface (ACPI) HAL, и будет использована стандартная версия HAL.


[0x0000007F] при установленном Symantec AntiVirus

[0x0000007F] при запуске Symantec AntiVirus Corporate Edition
Симптомы:
При запуске на компьютере программы Symantec AntiVirus Corporate Edition 8.0 или NSI Software`s Double-Take может возникнуть сообщение об ошибке
STOP 0x0000007F (0x00000008, 0x00000000, 0x00000000, 0x00000000) (UNEXPECTED_KERNEL_MODE_TRAP)

Причина:
Такая проблема может возникнуть, если пространства ядра на компьютере недостаточно для обработки драйверов в режиме ядра. Программы, указанные в начале статьи, устанавливают драйвер в режиме ядра и используют драйвер фильтра, регистрирующий в стеке ядра.
Для проверки файла на наличие вируса с помощью функции защиты файловой системы в режиме реального времени программам Symantec AntiVirus и Norton AntiVirus требуется доступ к файлам. Такие запросы на ввод-вывод файла могут занимать дополнительное пространство ядра, используемое компьютером.

Решение:
Для решения этой проблемы добавьте в реестр параметр KStackMinFree. Значение параметра KStackMinFree указывает минимальное пространство ядра, которое должно быть доступно программам Symantec AntiVirus или Norton AntiVirus для запросов ввода-вывода, направляемым к файловой системе.
Для добавления параметра используйте следующие инструкции.

При использовании Norton AntiVirus 7.6 или Symantec AntiVirus 8.x

1. Откройте редактор реестра и перейдите в ветку
HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Norton AntiVirus NT\Auto-Protect\InternalSettings

2. Создайте параметр типа DWORD с именем KStackMinFree и значением 2200.

3. Перезагрузите компьютер.

При использовании Symantec AntiVirus 9.x или более поздней версии.

1. Откройте редактор реестра и перейдите в ветку
HKEY_LOCAL_MACHINE\SOFTWARE\INTEL\LANDesk\VirusProtect6\CurrentVersion\Storages\Filesystem\RealTimeScan

2. Создайте параметр типа DWORD с именем KStackMinFree и значением 2200.

3. Перезагрузите компьютер.


[0x0000007F] при добавлении модуля памяти с использованием функции Hot Add Memory
Применяется к системам:
  • Microsoft Windows Server 2003 Service Pack 1:
    Microsoft Windows Server 2003 Enterprise Edition
    Microsoft Windows Server 2003 Standard Edition
    Microsoft Windows Server 2003 Web Edition

Симптомы:
Ошибка может возникать при следующих условиях:
- Ваш компьютер работает под управлением чипсета 64-bit
- На компьютере установлена 32-х разрядная версия Windows Server 2003 с пакетом исправлений 1 (SP1).
- Компьютер оборудован 4 Гигабайтами (GB) памяти.
- На компьютер добавлен модуль памяти. - После добавления модуля памяти объем памяти превысил 4 GB.
При выполнении данных условий компьютер перестает отвечать на запросы или появляется сообщение об ошибке "Stop 0x0000007F".

Причина:
Ошибка возникает из-за того, что Windows Server 2003 SP1 не может использовать двойную буферизацию DMA-доступа к памяти 32-х разрядных устройств.

Решение:
Для решения проблемы убедитесь, что у вас установлено как минимум 4 Гб оперативной памяти до включения функции Hot Add Memory
Или убедитесь что ваши устройства не ограничены использованием только 32-х битной DMA RAM.


[0x0000007F] однобитная ошибка в ESP регистре процессора

Однобитная ошибка в ESP регистре процессора вызывает STOP 0x0000007F (0x00000008,...)

0x0000007F (0x00000008, 0x00000000, 0x00000000, 0x00000000)
UNEXPECTED_KERNEL_MODE_TRAP

Симптомы
Ошибка может возникать на компьютерах под управлением Windows, оснащенных процессором Intel Xeon (или другими). При этом ошибка следующего вида
STOP 0x0000007F (0x00000008, 0x00000000, 0x00000000, 0x00000000) UNEXPECTED_KERNEL_MODE_TRAP

При возникновении ошибки наблюдаются следующие признаки.
- Первый параметр в данном сообщении равен 0x0000008 (ошибка является двойным исключением).
- Вследствие ошибки в одном из битов регистра ESP данный регистр содержит адрес, находящийся за пределами стека текущего потока.

Данная проблема возникает в следующих случаях.
- Система BIOS компьютера не загрузила обновление микрокода, необходимое для работы процессора компьютера.
- Процессор поврежден или неисправен.
- Нарушены условия эксплуатации процессора (процессор эксплуатируется при недопустимой температуре, неверном напряжении питания или с неверной частотой).

Решение

Способ 1
Определите, установлена ли на компьютере последняя версия обновления микрокода.
Обновление микрокода исправляет ошибки во внутренней логике процессора. Обновления микрокода не могут храниться в процессоре и загружаются в процессор при каждой загрузке компьютера. Загрузка обновлений микрокода выполняется системой BIOS или драйвером Update.sys.
Если на компьютере установлен процессор, выпущенный компанией Intel, то для определения версии обновления микрокода, загружаемого в данный процессор загрузите программу определения частоты процессора Intel с сайта
http://support.intel.com/support/processors/tools/frequencyid; после чего установите и запустите программу.
Запишите следующие сведения:
- семейство;
- модель;
- степпинг;
редакция.
Номера семейства, модели и степпинга однозначно определяют тип процессора. Редакция процессора позволяет определить версию загруженного обновления микрокода.
Признаки, описанные в данной статье, наиболее часто наблюдаются на процессорах Intel Xeon с номером семейства 15, номером модели 2 и степпингом 9, которые установлены на системных платах, использующих набор микросхем ServerWorks (шестнадцатеричные значения указанных выше номеров семейства, модели и степпинга равны F, 2 и 9 соответственно). Чтобы эти процессоры работали правильно, необходима редакция 0x18 или более поздняя (значение 0x18 — это шестнадцатеричное представление десятичного числа 24).
Если номер редакции равен 0, значит, система BIOS компьютера не содержит обновление микрокода для установленных на компьютере процессоров. В этом случае необходимо установить обновление для BIOS, которое содержит обновление микрокода, поддерживающее используемые процессоры.

Способ 2
Убедитесь, что процессор исправен
Если у вас есть такая возможность, то попробуйте установить ваш процессор на компьютер, на котором указанная проблема не возникает либо установите на компьютер на котором проблема наблюдается процессор с компьютера на котором данной проблемы нет.
Внимание! Не производите действия по замене процессора без должной квалификации.
Если после замены процессора на исходном компьютере проблема не исчезнет, а на компьютере, на который установлен исходный процессор, проблема не возникнет, то процессор, скорее всего, исправен и не является причиной ошибки.
Если после замены процессора на исходном компьютере проблема исчезнет, а на компьютере, на который установлен исходный процессор, проблема возникнет, то причиной проблемы, скорее всего, является неисправность процессора.

Способ 3
Проверьте, соблюдаются ли условия эксплуатации процессора.
Высокая температура в помещении, плохая вентиляция или накопление пыли могут вызывать сбои в работе процессоров и других компонентов. Проблемы с вентиляцией могут быть вызваны неработающими вентиляторами или закупоркой вентиляционных каналов. Если внутренняя часть или вентиляционные каналы компьютера заполнены пылью или если описанные признаки наблюдаются только при установке компьютера в определенных местах, причиной проблемы может быть перегрев. Убедитесь, что компоненты компьютера очищены от пыли, вентиляторы работают надлежащим образом, вентиляционные каналы свободны, а место установки компьютера надлежащим образом вентилируется.
Сбои в работе процессоров и других компонентов могут вызываться выходом напряжения питания за допустимые пределы, а также перепадами напряжения. Использование напряжения питания ненадлежащего номинала или плохого качества, перегрузка или сбои блока питания компьютера, а также сбои в работе компонентов системной платы могут привести к тому, что напряжение питания процессора выйдет за допустимые пределы или будет ненадлежащего качества.

Дополнительно

Регистр ESP также называют регистром указателя стека. Стек — это находящаяся в памяти структура данных, в которой хранятся сведения о текущем состоянии выполнения потока. Стек потока используется для отслеживания функций, выполняющихся в настоящий момент, а также для хранения параметров, передаваемых этим функциям, и переменных, используемых данными функциями. Регистр ESP должен содержать адрес вершины стека. Если данный регистр содержит ошибочное значение, он может ссылаться на неверные данные или недействительный адрес. Если регистр ESP ссылается на недействительный адрес, может возникнуть двойное исключение.
Чтобы определить, вызвана ли рассматриваемая STOP-ошибка ошибкой в одном из битов регистра ESP, выполните следующие действия.
1. Установите средство Microsoft Debugging Tools for Windows.
2. Запустите средство WinDbg, откройте нужный файл дампа памяти через меню File -> Open Crash Dump.
Информация, отображаемая при начальном анализе файла дампа, может выглядеть следующим образом.

3. Чтобы автоматически проанализировать файл дампа, выполните команду !analyze -v. Ниже показан пример выходных данных команды !analyze -v.

4. Проанализируйте результаты работы команды !analyze -v и определите, содержатся ли в них сведения о возникновении двойной ошибки. Если будет обнаружена двойная ошибка, выполните команду .tss 28, чтобы отобразить состояние системы в момент возникновения данной ошибки. В приведенном ниже примере показаны значения регистров процессора в момент возникновения двойного исключения.

В данном примере в регистре ESP содержится значение f5da9948. Как правило, адрес, хранящийся в регистре ESP, незначительно отличается от адреса, хранящегося в регистре EBP. В данном примере в регистре EBP содержится значение f5d2997c.

5. Выполните команду !thread, чтобы отобразить диапазон адресов, выделенный под стек текущего потока. Как правило, двойное исключение возникает в тех случаях, когда адрес, хранящийся в регистре ESP, находится за пределами диапазона адресов, зарезервированных для стека текущего потока. Ниже показан пример выходных данных команды !thread.

В данном примере диапазон адресов, выделенных под стек, отображается в следующей строке.

Stack Init f5d2a000 Current f5d29c9c Base f5d2a000 Limit f5d27000 Call 0
При работе потока значение регистра ESP должно находиться в пределах между базовым (Base, f5d2a000) и минимальным (Limit, f5d27000) адресами стека. Как правило, адрес, хранящийся в регистре регистра ESP, незначительно отличается от текущего адреса (Current, f5d29c9c). Текущий адрес также находится между базовым и минимальным адресами. В данном примере в регистре ESP содержится значение f5da9948. Этот адрес находится далеко за пределами диапазона адресов, выделенных для стека.
Чтобы определить диапазон адресов, выделенных под стек, можно также воспользоваться командой !pcr. Ниже показан пример выходных данных команды !pcr.

Значение NtTib.StackLimit представляет собой младший адрес из диапазона адресов, выделенных под стек. NtTib.StackBase — это последнее значение регистра ESP. Чтобы определить, возникла ли в одном из битов регистра ESP ошибка, сравните текущее значение регистра ESP со значением NtTib.StackBase.

6. Чтобы определить разницу между значениями регистров ESP и EBP, выполните команду .formats esp ^ ebp. Если ошибка не возникала, значение, хранящееся в регистре EBP, будет незначительно отличаться от значения указателя стека, хранящегося в регистре ESP. Как правило, использование этой команды позволяет обнаружить старший бит регистра ESP, содержащий ошибку. Обнаружение данного бита облегчается при отображении результатов в двоичном виде, как показано в следующем примере.

Если не рассматривать младшие (менее значимые) биты, то значения регистров ESP и EBP отличаются одним битом. Разность этих значений равна 00000000 00001000 00000000 00000000 (в двоичном виде) или 00080000 (в шестнадцатеричном виде).
Это показывает, что в одном из битов регистра ESP возникла ошибка, в результате чего данный регистр содержит неправильное значение, которое приводит к появлению двойного исключения, системной ошибки и аварийному завершению работы системы.

Для получения дополнительных сведений об используемом оборудовании выполните следующие действия.
1. Выполните команду !cpuinfo, чтобы получить сведения о процессоре. Ниже показан пример выходных данных команды !cpuinfo.

Для всех перечисленных PCI-устройств первое шестнадцатеричное значение в каждой строке (это значение состоит из 8 цифр и имеет тип DWORD) представляет собой идентификатор производителя и устройства (VenDev ID). Фактически идентификатор производителя определяется последними четырьмя цифрами. Например, первое устройство в приведенном выше списке имеет идентификатор VenDev ID, равный 0x00141166. При этом идентификатор устройства (Device ID) равен 0x0014, а идентификатор производителя (Vendor ID) — 0x1166. Идентификатор производителя для наборов микросхем ServerWorks равен 0x1166. Это означает, что выше приведен результат работы команды !pcitree на компьютере с системной платой, использующей набор микросхем ServerWorks.


0x00000085: SETUP_FAILURE
Примечание: текстовая форма setup больше не использует проверку ошибок (bugcheck), чтобы выйти из серьёзных ошибок. Поэтому вы никогда не столкнётесь с 0x85. Все проверки багов были заменены на более дружелюбные и (где возможно) более информативные сообщения об ошибках. Тем не менее, некоторые составители ошибок просто были заменены нашими bugcheck экранами, и код для этих состояний ошибок такой же, как и был. Они приведены ниже.)

0: OEM HAL шрифт - недействительный формат файла *.fon, поэтому установка не смогла отобразить текст. Это означает, что vgaxxx.fon на CD или флоппи повреждён.
1: Не смогло инициализироваться видео. Эта ошибка имеет собственный экран и пользователю предоставляется только 2 варианта.
Это означает, что файл vga.sys (или другой драйвер, в зависимости от машины) повреждён, или то, что данное оборудование не поддерживается.
Причина ошибки:
0: NtCreateFile of devicevideo0
1: IOCTL_VIDEO_QUERY_NUM_AVAIL_MODES
2: IOCTL_VIDEO_QUERY_AVAIL_MODES
3: Желаемый режим видео не поддерживается. Это означает внутреннюю ошибку установки.
4: IOCTL_VIDEO_SET_CURRENT_MODE (невозможно установить режим видео)
5: IOCTL_VIDEO_MAP_VIDEO_MEMORY
6: IOCTL_VIDEO_LOAD_AND_SET_FONT (3 - код статуса NT API вызова)

2: Нехватка памяти. Теперь эта ошибка использует более дружественный экран, в зависимости от того, как далеко зашла установка.
3: Клавиатура не была инициализирована. Теперь используются 2 разных экрана в зависимости от ошибок, которые тут могли появиться. Это может означать, что диск, содержащий драйвера для клавиатуры (i8042prt.sys или kbdclass.sys) повреждён или машина имеет клавиатуру, которая не поддерживается.
Так же это может означать, что dll раскладки клавиатуры не может быть загружен.
Причина ошибки:
0: NtCreateFile of deviceKeyboardClass0 .
"Установка не обнаружила клавиатуру, подключённую к вашему компьютеру."
1: Unable to load keyboard layout dll.
"Установка не может загрузить dll раскладки клавиатуры ."
Это значит, что на флоппи или CD нет файла (kbdus.dll для us или других dll).
4: Установка не смогла выяснить путь устройства, с которого началась установка. Это внутренняя ошибка установки.
5: Не прошла проверка на работоспособность разделов жесткого диска. Это означает, что ошибка в драйвере диска. Параметры имеют значение только для группы установки.


0x0000008B: MBR_CHECKSUM_MISMATCH
Эта ошибка возникает в процессе загрузки, когда контрольная сумма MBR, которую посчитала система, не совпадает с контрольной суммой загрузчика. Обычно это означает вирус. Некоторые вирусы не могут быть определены/найдены. Загрузитесь с дискеты с вирус-сканером (убедитесь, что дискета защищена от записи!)
KerBugCheckEx

Параметры:
1 - Disk Signature from MBR.
2 - MBR контрольная сумма вычислена загрузчиком системы.
3 - MBR контрольная сумма вычислена системой.


0x0000008E
Применяется к следующим системам:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1

"STOP 0x0000008e" Error Message During Windows XP Setup

Microsoft Windows XP Professional
Microsoft Windows XP Home Edition
Установка может прерваться следующей ошибкой :
STOP 0x0000008e
или
STOP 0x00000050 PAGE_FAULT_IN_NON_PAGED_AREA
И если для решения проблемы вы удаляете всё второстепенное оборудование из компьютера и после этого начнаете установку заново, можете получить следующую ошибку:
Setup cannot copy the file Setupdd.sys.

Это может случиться, если один из приведённых ниже вариантов применяется:
  1. Один или несколько RAM модулей установленных на вашем компьютере не исправны.
  2. Конфигурация RAM не совместима с Windows XP.
Решение:
1. Удалите некоторые модули RAM памяти и оставьте хотя бы столько, чтобы можно было запустить Windows XP.
Рекомендовано - 128, минимум - 64, максимум - 4Г.
2. Перезагрузите компьютер и запустите установку.
Если вы опять получаете этот же стоп, то переходите к пункту 3.
3. Попробуйте другой модуль или поставьте этот модуль в другой слот.
4. Перезагрузите компьютер и запустите установку снова.

Примечание: ошибки 0x00000050 и 0x0000008E в большинстве случаев указывают на неисправную RAM память.

STOP 0x0000008E Error Message on a Blue Screen and Your Computer Does Not Enter Hibernation or Standby After You Remove an IEEE 1394 Storage Device

Применяется к следующим системам:
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1

После удаления IEEE 1394 накопительного устройства, такое как CD-ROM или внешний винчестер из компьютера под Windows XP Service Pack 1 (SP1) у Вас могли возникнуть следующие проблемы:
1. Когда вы погружаете ваш компьютер в сон (hibernation):
*** STOP: 0x0000008E (0xC00000005, 0x804EF844, 0xF89463FC,0x00000000)
2. Когда вы погружаете ваш компьютер в standby, монитор выключается, как нужно, но индикатор показывает, что компьютер не в standby.

Это может случиться, если приведённые ниже варианты применяются:
1. Апдейт - 329909 IEEE 1394 Storage Device Detection Does Not Work When the System Resumes from Standby or Hibernation - установлен на ваш компьютер.
И
2. Вы удалили IEEE 1394 накопительное устройство, пользуясь Safely Remove Hardware, а потом погрузили ваш компьютер в сон (hibernation) или standby
Примечание: Оговаривается случай, когда IEEE 1394 накопительное устройство удалено из Windows XP, но физический ещё подключено к компьютеру.

Решение:
Уже есть решение этой проблемы, но оно поможет только в ситуации описанной вверху. Применяйте его только к компьютеру с такой проблемой. Поэтому, если вы не сильно обременены этой проблемой, Microsoft рекомендует подождать до выхода следующего SP, который должен решить проблему.
Чтобы решить проблему немедленно, свяжитесь с Microsoft Product Support Services, для выяснения номеров телефонов и стоимости звонков и услуг, посетите сайт Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
Примечание: В некоторых случаях, стоимость звонка может быть отменена, если Microsoft выяснит, что конкретный патч поможет решить эту проблему. В остальных случаях, когда обсуждаются вопросы, не относящиеся к конкретному случаю, плата будет взыскана.


0x0000008F: PP0_INITIALIZATION_FAILED
Это сообщение появляется, если инициализация фазы 0 менеджера Plug and Play не прошла на стадии инициализации ядра (kernel-mode Plug and Play Manager failed). Вообще-то нет ничего такого, что бы могло вызвать эту ошибку.


0x00000090: PP1_INITIALIZATION_FAILED
Это сообщение появляется, если инициализация фазы 1 менеджера Plug and Play не прошла на стадии инициализации ядра (kernel-mode Plug and Play Manager failed). Вот здесь происходят практический все инициализации, включая конфигурацию среды (реестр и т.д.) драйверов для вызова I/O впоследствии.


0x00000092: UP_DRIVER_ON_MP_SYSTEM
Эта ошибка появляется только когда UNIPROCESSOR драйвер загружается на систему, в которой больше чем один активный процессор.
KeBugCheckEx

Параметры:
1. адрес базы драйвера.


0x00000093: INVALID_KERNEL_HANDLE
Эта ошибка появляется, когда код ядра (kernel code), такой, как сервер, перенаправитель (redirector), другие драйвера пытаются закрыть не действительный указатель.

Параметры:
1 - указатель, с которым NtClose был вызван.
2 - 0 означает, что был закрыт защищённый указатель.
1 значит, был закрыт неверный указатель.


0x00000096: INVALID_WORK_QUEUE_ITEM
Это сообщение появляется, когда KeRemoveQueue удаляет очередь данных, а flink или blink поля равны 0. Это практический всегда вызывается неправильным применением кода работающей нити текущего объекта, хотя неправильное применение любой очереди может привести к этому.
Правило - ввод данных в очередь может быть произведено только однажды. Когда предмет удаляется из очереди, его flink поле равно 0.

Для того, чтобы устранить эту ошибку, вам необходимо выяснить очередь, на которую он ссылается. Если эта очередь одна из ЕХ работающих очередей (ExWorkerQueue), тогда объект, который удаляется - WORK_QUEUE_ITEM. Эта ошибка подразумевает, что это и есть причина. Параметры ошибки могут помочь выявить драйвер, который неправильно использует очередь.


0x00000097: BOUND_IMAGE_UNSUPPORTED
MmLoadSystemImage была вызвана, чтобы загрузить bound image. Это не поддерживается ядром. Убедитесь, что bind.exe не был запушен для картинки.KeBugCheckEx

Параметры:
1 - Адрес данных в очереди, flink/blink поле которых ноль.
2 - Адрес на ссылающуюся очередь. Обычно это одна из ExWorkerQueues очередей.
3 - Начальный адресс ExWorkerQueue массива. Это поможет выявить, если очередь в вопросе одна из ExWorkerQueue очередей и если так, то офсет из этого параметра выявит очередь.
4 - Если это ExWorkerQueue очередь (как это бывает обычно), это адрес работающей рутины, которая бы вызывалась, если работающий элемент был бы действительным. Это может быть использовано, чтобы выявить драйвер, который неправильно использует рабочую очередь.


0x00000098: END_OF_NT_EVALUATION_PERIOD
Указывает на то, что ознакомительный период работы системы истек.

KeBugCheckEx

Параметры:
1 - Низкий 32-битный запрос вашей даты инсталляции.
2 - Высокий 32-битный запрос вашей даты инсталляции.
3 - Ознакомительный период в минутах.


0x0000009C: MACHINE_CHECK_EXCEPTION
Фатальная ошибка Machine Check Exception (проверка машины).
KeBugCheckEx параметры:
Если процессору доступныТОЛЬКО MCE функции (например: Intel Pentium), то параметры будут:
1 - Low 32 bits of P5_MC_TYPE MSR
2 -
3 - High 32 bits of P5_MC_ADDR MSR
4 - Low 32 bits of P5_MC_ADDR MSR
Если процессор так же имеет MCA функции (например: Intel Pentium Pro), то параметры будут:
1 - Пустой номер
2 - Адрес поля MCi_ADDR MSR MCA, где ошибка случилась
3 - High 32 bits MCi_STATUS MSR, где ошибка случилась
4 - Low 32 bits MCi_STATUS MSR, где ошибка случилась

Windows XP:

STOP: 0x0000009C (0x00000004, 0x00000000, 0xb2000000, 0x00020151)
"MACHINE_CHECK_EXCEPTION"
(четыре параметра в скобках могут быть разными)

Причина:
Это происходит из-за того, что процессор вашего компьютера обнаруживает ошибку и сообщает об этом Windows XP. Чтобы сделать это он использует Machine Check Exception (MCE) для процессоров Pentium или Machine Check Architecture (MCA) для некоторых процессоров Pentium Pro. Ошибка может вызываться следующим:
  1. Ошибки системной шины
  2. Проблемы с чётностью в памяти или Error Correction Code (ECC)
  3. Проблемы кеширования в процессоре или в оборудовании
  4. Translation Lookaside Buffers (TLB) проблемы в процессоре
  5. Другие проблемы с процессором
  6. Другие проблемы с оборудованием

Статус:
Такое поведение специально спланировано Microsoft

Решение:
Ошибка может возникнуть если:
1. Вы разогнали (overclocking) процессор или шину. В этом случае, установите параметры работы рекомендуемые производителем.
2. Не стабильный блок питания. Удостоверьтесь, что ваш БП работает корректно.
3. Перегрев. Перегрев каких либо компонентов может привести к этой ошибке. Убедитесь, что все вентиляторы работают исправно.
4. Повреждённая память или память не подходящая для вашего компьютера. Убедитесь, что память работает исправно и модель совместима с вашей конфигурацией.

Добавление:
Такая ошибка так же может возникнуть если:
1. Вы изменили параметры в BIOS, влияющие на конфигурацию ядра системы
2. Вы установили ХР с образа чужой системы
3. У вас не правильно подключено какое-то оборудование

Происходит это из-за того что проверка машины не соответствует уже установленной конфигурации ядра.


0x0000009F: DRIVER_POWER_STATE_FAILURE
Применяется к следующим системам:

Microsoft Windows 2000

DRIVER_POWER_STATE_FAILURE

Причина:
Причиной этого стопа является драйвер устройства, который не выдержал вызова на переход в другое состояние электропитания.

Решение:
Вы должны обновить или удалить неработоспособный драйвер устройства или драйвер-фильтр файловой системы (file system filter driver), который, возможно, был установлен антивирусной программой, программой удалённого доступа или ПО CDW/CDRW.

Для обнаружения драйвера примените следующие:
1. Используйте %SystemRoot%\System32\Sigverif.exe чтобы проверить на драйвера, которые не проходили тесты Microsoft (unsigned drivers).
2. Проверьте обновления драйверов у поставщика вашей системы.
3. Обновите ПО, которое может иметь драйвера-фильтр файловой системы (file system filter drivers).
4. Удалите компоненты оборудования, а так же ПО, которые не обязательны.
5. Установите ещё один Windows 2000 на другой раздел жесткого диска. И устанавливаете ПО, тут же проверяя, пока не выявите уязвимую программу.


0x000000B4: VIDEO_DRIVER_INIT_FAILURE
Windows не удалось перейти в графический режим, потому что ни один видео драйвер не был загружен. Обычно проблема с драйвером или какой-то конфликт видео оборудования с другим оборудованием. Загрузитесь в Safe Mode и посмотрите, если это решит проблему. Если так, то обновите драйвера видео оборудования или откатите на рабочую версию.


0x000000BE: ATTEMPTED_WRITE_TO_READONLY_MEMORY
Драйвер попытался записать в read-only (только чтение) память. Обычно возникает после установки неисправного драйвера оборудования, системного сервиса, BIOS`a. Если имя драйвера указано в ошибке, попытайтесь исправть проблему отключением, удалением или откаткой драйверов.

Применяется к следующим системам:
  • Windows 2000 Datacenter Server
ATTEMPTED_WRITE_TO_READONLY_MEMORY

 Обычная причина: плохой или повреждённый драйвер неправильно функционирует.

Решение:

1. Отключите драйвер, указанный на стоп-экране или все, только что установленные драйвера. Если вы не можете загрузить компьютер, попробуйте воспользоваться Last Known Good Configuration или загрузиться в безопасном режиме (safe mode). И после этого отключите или удалить все новоустановленные драйвера и программное обеспечение.
Для большей информации смотрите статью Safe mode startup options. Если ваш компьютер не запускается в безопасном режиме, воспользуйтесь Recover a system that will not start.

Важно:
Когда вы используете Last Known Good Configuration, системные установки с последней успешной загрузки, будут утеряны.

2. Попытайтесь заменить драйвер хорошей копией с инсталляционного диска или скачать новую версию с сайта производителя.


0x000000C1: SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION
Попытка произвести запись драйвером по неправильному адресу памяти.

Примечание: Эта ошибка возникает в 99% из-за неполадок в драйверах. Некоторые из них в Windows XP вы можете обнаружить, используя утилиту verifier.exe: Start (Пуск) => Run (Выполнить) => verifier.exe

Windows NT/2000/XP:

Эта ошибка схожа с ошибками:
  1. 0x0A IRQL_NOT_LESS_OR_EQUAL, указывает, что драйвер затронул память на DISPATCH_LEVEL уровне или выше.
  2. 0xBE ATTEMPTED_WRITE_TO_READONLY_MEMORY, драйвер пытался записать в память "только чтение".
  3. 0xC1 SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION, драйвер попытался записать в неверный адрес памяти.
  4. 0xC4 DRIVER_VERIFIER_DETECTED_VIOLATION, обычно фатальная ошибка.
  5. 0xC5 DRIVER_CORRUPTED_EXPOOL, указывает на то, что драйвер попытался обратиться к неверной памяти на процессе IRQL, который слишком высок.
  6. 0xC6 DRIVER_CAUGHT_MODIFYING_FREED_POOL, драйвер пытался получить доступ к высвобожденному сектору памяти.
  7. 0xC7 TIMER_OR_DPC_INVALID, указывает, что таймер ядра или DPC был обнаружен в памяти, где его не должно было быть. Такая ситуация обычно возникает, когда драйвер не отменил таймер или the Delayed Procedure Call (DPC) перед тем как освободить память занятую таймером или DPC.
  8. 0xC9 DRIVER_VERIFIER_IOMANAGER_VIOLATION, I/O нарушение инструмента проверки драйверов.
  9. 0x50 PAGE_FAULT_IN_NONPAGED_AREA, указание на неверную системную память.
Решение:
Используйте Driver Verifier для выявления ошибок и повреждённых драйверов. Переустановите драйвера определенные утилитой как сбойные.


0x000000C2: BAD_POOL_CALLER
STOP 0x000000C5 DRIVER_CORRUPTED_EXPOOL
Процесс ядра или драйвер попытались неверно произвести операцию с памятью. Обычно причиной являются неисправные драйвера или софт.

Windows 2000 XP

Применяется к следующим системам:
  1. Microsoft Windows 2000 Server
  2. Microsoft Windows 2000 Advanced Server
  3. Microsoft Windows 2000 Datacenter Server
  4. Microsoft Windows 2000 Professional
  5. Microsoft Windows XP 64-Bit Edition
  6. Microsoft Windows XP Home Edition
  7. Microsoft Windows XP Professional
Решение:
Windows 2000 содержит много различных встроенных фич, которые усиливают процесс распределение памяти (pool allocation process). Эти фичи могут помочь вам установить корневую причину ошибки простым дебагом (debugging).
Следуйте следующим шагам:
            BAD_POOL_CALLER (0xC2)
Текущая нить неправильно обращается к памяти. Обычно, это из-за
            неверного уровня IRQL или двойного освобождения одного и того же
            места памяти, и т.д.

1 - тип нарушения обращения к бассеину.
6 - адрес освобождаемого бассеина, который уже был освобождён.
7 - адрес освобождаемого бассеина, который уже был освобождён.
8 - переметр 2 - это IRQL расположения, параметр 3 - тип
9 - переметр 2 - это IRQL высвобождения, параметр 3 - тип

Parameter 1 = 0x1, 0x2, or 0x4 : заголовок басейна повреждён
Parameter 2 = указатель на заголовок
Parameter 3 = первая чать содержания заголовка
Parameter 4 = 0

Parameter 1 = 0x6 : попытка освободить пямять, которая уже свободна
Parameter 2 = резерв (__LINE__)
Parameter 3 = указатель на заголовок
Parameter 4 = содержание заголовока

Parameter 1 = 0x7 : попытка освободить пямять, которая уже свободна
Parameter 2 = резерв (__LINE__)
Parameter 3 = указатель на заголовок
Parameter 4 = 0

Parameter 1 = 0x8 : попытка освободить пямять используя неверный
            IRQL
Parameter 2 = текущий IRQL
Parameter 3 = тип басейна памяти
Parameter 4 = его размер

Parameter 1 = 0x9 : попытка освободить пямять используя неверный
            IRQL
Parameter 2 = текущий IRQL
Parameter 3 = тип басейна памяти
Parameter 4 = его адрес

Parameter 1 = 0x40 : попытка освободить пользовательский адрес для
            ядра
Parameter 2 = адрес начала
Parameter 3 = начало системного места
Parameter 4 = 0

Parameter 1 = 0x41 : попытка освободить неиспользуемый адрес
Parameter 2 = адрес начала
Parameter 3 = рамка физической страницы
Parameter 4 = наибольшая рамка

Parameter 1 = 0x50 : попытка освободить неиспользуемый адрес
Parameter 2 = адрес начала
Parameter 3 = Start offset in pages from beginning of paged pool
Parameter 4 = размер в байтах

Parameter 1 = 0x99 : попытка освободить неверный адрес памяти (или
            повреждение заголовка)
Parameter 2 = освобождаемый адрес
Parameter 3 = 0
Parameter 4 = 0
После того, как вы выяснили детальную информацию по ошибке, воспользуйтесь дебагером.
E:bin>i386kd -z K:DOWNLOADmemory.dmp
Loading Dump File [K:DOWNLOADmemory.dmp]
Full Kernel Dump File...

0: kd> !reload GOOD HOUSEKEEPING DONE HERE
0: kd> dd kibugcheckdata l8 DUMPING THE ERROR
8047fba0 000000c2 00000007 00000b68 815bade0
8047fbb0 815bade8 e1007000 00000000 818988c0
0: kd> kv DUMPING STACK

ChildEBP RetAddr Args to Child
bdce0348 be11dc84 e1fff000 a08d0008 000007f8 banshee!vH3ImageTransferMm32
bdce037c be116f18 be85fd78 00000001 bdce03dc banshee!vMmXferNative
bdce03ac be113eec e1fff000 e25e2a38 bdce03dc banshee!vPutBits
bdce03e8 a008e47f e1ff86f8 e25e2a38 e1fef908 banshee!DrvCopyBits
bdce0430 a008e899 be113d40 bdce04d8 e1ff86f8 win32k!OffCopyBits
bdce04e4 a008e4d1 e1ff86f8 e25e2a38 00000000 win32k!SpBitBlt
Документация ошибки указывает, что память была освобождена. Это явно из линии:
Parameter 1 = 0x7: Attempt to free pool which was already freed.
Так же видно, что видео карта в процессе записи, поэтому мы должны продолжать работу над ошибкой. Во-первых, мы должны выявить, если этот компьютер мультипроцессорный:
0: kd> ~1 SWITCH PROC
1: kd> kv DUMPING STACK
ChildEBP RetAddr Args to Child
bde81b7c 8046894d 815bade8 00000000 be03bb2b ntkrnlmp!ExFreePoolWithTag
bde81b88 be03bb2b 815bade8 be03ca94 815bade8 ntkrnlmp!ExFreePool
00000128 00000000 00000000 00000000 00000000 BADDRIVER
Предыдущий текст указывает, что память была освобождена драйвером имя_драйвера. Это может быть корневой причиной.
Теперь выявим драйвер.
1: kd> !drivers
Loaded System Driver Summary

Base Code Size Data Size Driver Name Creation Time
80400000 139f40 (1255 kb) 4f3c0 (316 kb) ntoskrnl.exe Tue Dec 07 14:05:26 1999
80062000 ffe0 ( 63 kb) 3d60 ( 15 kb) hal.dll Tue Nov 02 20:14:22 1999
ed410000 1760 ( 5 kb) 1000 ( 4 kb) BOOTVID.dll Wed Nov 03 20:24:33 1999
ed49c000 1b00 ( 6 kb) 680 ( 1 kb) gameenum.sys Sat Sep 25 14:35:57 1999
ed080000 a000 ( 40 kb) 20c0 ( 8 kb) VIDEOPRT.SYS Sat Nov 06 16:55:20 1999
bfdcf000 1d480 ( 117 kb) 7520 ( 29 kb) mga64m.sys Mon Nov 29 20:47:46 1999
bfdbc000 11600 ( 69 kb) 1600 ( 5 kb) el90xnd5.sys Fri Oct 29 17:54:34 1999
ed090000 3a60 ( 14 kb) 5980 ( 22 kb) banshee.sys Fri Oct 29 19:00:56 1999
ed5df000 2e0 ( 0 kb) 4a0 ( 1 kb) audstub.sys Sat Sep 25 14:35:33 1999
ed370000 33e0 ( 12 kb) a40 ( 2 kb) raspti.sys Fri Oct 08 16:45:10 1999
ed0c0000 c5e0 ( 49 kb) 20e0 ( 8 kb) parallel.sys Fri Oct 22 18:00:54 1999
ed5e0000 580 ( 1 kb) 540 ( 1 kb) swenum.sys Sat Sep 25 14:36:31 1999
be552000 72a60 ( 458 kb) 13c40 ( 79 kb) mga64d.dll Tue Nov 30 04:33:19 1999
be113000 36f00 ( 219 kb) 7a20 ( 30 kb) banshee.dll Tue Nov 30 04:31:18 1999
be031000 FFFF ( FF kb) FFFF ( F kb) BADDRIVER.sys Mon Feb 30 23:22:43 2000

TOTAL: 7f8dc0 (8163 kb) 172140 (1480 kb) ( 0 kb 0 kb)
Предыдущий текст показывает, что драйвер используется ПО третьей стороны. Этот драйвер, скорей всего, и есть главная причина ошибки.

Microsoft Debugging Tools
http://www.microsoft.com/ddk/debugging/default.asp


0x000000C5: DRIVER_CORRUPTED_EXPOOL
STOP 0x000000C5 DRIVER_CORRUPTED_EXPOOL

Почти всегда причиной является неисправный драйвер. Если вы только что установили новое программное обеспечение, проверьте обновление его драйверов на сайте производителя.

Применяется к следующим системам:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional

Причина: эта ошибка возникает при попытке затронуть недействительную память на процессе IRQL, который слишком высок.
Примечание: ошибка схожа с ошибкой IRQL_NOT_LESS_OR_EQUAL

Решение:
Для решения этой проблемы воспользуйтесь Driver Verifier, если это не решит проблемы, используйте gflags для включения Special Pool feature.
Для дополнительной информации, как использовать Driver Verifier, прочитайте статью 244617
Для дополнительной информации, как включить Special Pool feature, прочитайте статью 188831

"Stop 0x1E" or "Stop 0xc5" After You Install Service Pack 2 and You Use Logitech Mouse Drivers

Применяется к следующим системам:
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP2

Причина: ошибка появляется, потому что вы используете USB Logitech мышь и Logitech Mouseware версии 9.29.2 или раньше.

Решение:
Для решения проблемы скачайте MouseWare с http://www.logitech.com.
Чтобы правильно запустить компьютер, воспользуйтесь одним из следующих способов:

Метод 1:
Если вы хотите иметь возможность в последствии удалить Service Pack 2:
1. Загрузитесь в Windows 2000 Recovery Console.
2. Зарегистрируйтесь с администраторским паролем.
3. Напечатайте следующие и нажимайте ENTER после каждой строки:
cd $Ntservicepackuninstall$
copy i8042prt.sys c:\winnt\system32\drivers (нажмите Y чтобы переписать файл)
4. По вызову, напечатайте exit, нажмите ENTER чтобы перезагрузить компьютер.

Метод 2:
Если не хотите:
1. Загрузитесь в Windows 2000 Recovery Console.
2. Зарегистрируйтесь с администраторским паролем.
3. Напечатайте следующие и нажимайте ENTER после каждой строки:
cd system32\drivers
ren L8042pr2.sys L8042pr2.old
copy i8042prt.sys L8042pr2.sys
4. По вызову, напечатайте exit, нажмите ENTER чтобы перезагрузить компьютер.


0x000000D1: DRIVER_IRQL_NOT_LESS_OR_EQUAL
Была сделана попытка затронуть виртуальную память на внутреннем процессе IRQ уровня, который слишком высок.

Возможные причины:

Неполадки в работе драйвера
Неполадки в работе модуля памяти
Поврежден файл подкачки

0x000000D1: DRIVER_IRQL_NOT_LESS_OR_EQUAL (общий обзор)

0x000000D1: Возникновение ошибки в драйвере BLACKDRV.SYS

0x000000D1: Возникновение ошибки в драйвере gv3.sys при работе с портативным компьютером в Windows XP

0x000000D1: Возникновение ошибки в драйвере Kbdclass.sys при выключении компьютера

0x000000D1: Возникновение ошибки в драйвере Scsiport.sys

0x000000D1: Возникновение ошибки из-за неисправного модуля памяти или поврежденого файл подкачки

0x000000D1: Возникновение ошибки послери установки связи через VPN

0x000000D1: Возникновение ошибки при выключении компьютера

0x000000D1: Возникновение ошибки при выходе из ждущего/спящего режима

0x000000D1: Возникновение ошибки при запуске Laplink PCsync

0x000000D1: Возникновение ошибки при установленной программе Agnitum Outpost Firewall

0x000000D1: Возникновение ошибки при установленной программе WRQ AtGuard

0x000000D1: DRIVER_IRQL_NOT_LESS_OR_EQUAL (общий обзор)

Была сделана попытка затронуть виртуальную память на внутреннем процессе IRQ уровня, который слишком высок.

Информация применяется к:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

Статья - Q317326
Когда к Вашему компьютеру подключены один или несколько устройств на universal serial bus (USB), может возникнуть такая ошибка во время выключении компьютера:
Stop 0x000000D1 (0x00000040, 0x00000002, 0x00000000, 0xfc96a9dc)

Проблема появляется потому, что OHCI endpoint не может найти описание перевода данных в списке.

Решение:
Для решения этой проблемы, обновить последний SP для Windows XP. Для дополнительной информации воспользуйтесь следующей статьёй:
322389 How to Obtain the Latest Windows XP Service Pack
В английской версии должен присутствовать файл со следующими атрибутами или позже:
Date Time Version Size File name
--------------------------------------------------
06-Feb-02 18:30 5.1.2600.28 15,616 Usbohci.sys

Microsoft подтверждает, что проблема в продукте Microsoft.

Когда вы пытаетесь выключить компьютер, можете получить следующие BSOD:D:
STOP 0x000000D1, (0x0000002b, 0x00000002, 0x00000000, 0xEEEE1b01) IRQL_NOT_LESS_OR_EQUAL Kbdclass.sys.
Stop 0x0000007E (0xc0000005, 0xFC7F1945, 0xFC9589B0, 0xFC9586B0) Kbdclass.sys - address Fc7F1945 base at FC7F1000, Datestamp 3b7d82f3
STOP 0x000000D1 может быть вызван, если вы используете Logitech MouseWare версий 9.10 и 9.24.
STOP 0x0000007E может быть вызван, если вы используете Logitech iTouch ПО версии 1.5 или раннее.

Решение:

0x000000D1:
1. Удалите Logitech MouseWare программы с вашего компьютера.
2. Выключите и включите комп снова.
3. Посетите сайт http://www.logitech.com чтобы получить последние версии ПО.
4. Установите новую Logitech MouseWare.

0x0000007E:
1. Посетите http://www.logitech.com и скачайте последние версии iTouch драйверов.
2. Установите новые iTouch драйвера.

вверх

0x000000D1: Возникновение ошибки в драйвере BLACKDRV.SYS

(MSKB 269279)

При копировании больших файлов по сети или при открытии вкладки "Дополнительно" в свойствах системы вы можете получить следующее сообщение об ошибке:
Stop 0X000000D1 (0XBE70D600, 0X00000000,0X00000000,0XBE92F13C)
DRIVER_IRQL_NOT_LESS_OR_EQUAL
Address BE92F13C Base at BE92C000, date Stamp 394006612 BLACKDRV.SYS

Решение:

• Отключите службы использующие BlackICE
1. Переименуйте файл из Recovery Console используя команды
disable black
disable blackice
cd winnt\system32\drivers
ren blackdrv.sys blackdrv.old
exit
• Загрузите и установите последнюю версию программы BlackICE PC Protection

вверхрх

0x000000D1: Возникновение ошибки в драйвере gv3.sys при работе с портативным компьютером в Windows XP

(MSKB 888399)
STOP 0x000000D1 (0x0000000C, 0x00000002, 0x00000000, 0xF8E26A89)
gv3.sys – Address F8E26A89 base at F8E26000, Datestamp 3dd991eb

Сообщение об ошибке может возникать при переключении портативного компьютера под управлением Microsoft Windows XP с пакетом обновления 2 (SP2) с питания от сети переменного тока на питание от батарей или наоборот.
Причина:
Возможно, если на портативном компьютере с мобильным процессором Intel Pentium M (Centrino) драйвер процессора Gv3.sys принудительно установлен в Windows XP с пакетом обновления 2 (SP2).
Драйвер процессора Gv3.sys был разработан для обеспечения поддержки функций управления питанием мобильных процессоров Intel Pentium M под управлением Windows XP и Windows XP с пакетом обновления 1 (SP1).
В настоящее время этот драйвер является устаревшим и в Windows XP с пакетом обновления 2 (SP2) не поддерживается.
Драйвер процессора Gv3.sys заменен драйвером процессора Intelppm.sys. Драйвер процессора Gv3.sys может принудительно устанавливаться в Windows XP с пакетом обновления 2 (SP2) программой установки драйверов OEM.

Решение:

1. В меню Пуск выберите команду Выполнить, введите devmgmt.msc и нажмите клавишу ВВОД.
2. В диспетчере устройств разверните узел Процессоры.
3. Щелкните правой кнопкой мыши Процессор Intel Pentium M и выберите пункт Обновить драйвер.
Запустится мастер обновления драйвера.
4. В случае появления вопроса Подключиться к Windows Update для поиска данной программы? нажмите кнопку Нет, как-нибудь в другой раз, а затем – кнопку Далее.
5. Выберите пункт Автоматическая установка (рекомендуется) и нажмите кнопку Далее.
6. Нажмите Готово.

вверх

0x000000D1: Возникновение ошибки в драйвере Kbdclass.sys при выключении компьютера

Stop 0x00002b, 0x00000002, 0x00000000, 0xEEEE1b01) IRQL_NOT_LESS_OR_EQUAL Kbdclass.sys.

Когда вы пытаетесь выключить компьютер, можете получить следующие BSOD:
STOP 0x000000D1, (0x000000007E (0xc0000005, 0xFC7F1945, 0xFC9589B0, 0xFC9586B0) Kbdclass.sys - address Fc7F1945 base at FC7F1000, Datestamp 3b7d82f3
STOP 0x000000D1 может быть вызван, если вы используете Logitech MouseWare версий 9.10 и 9.24.
STOP 0x0000007E может быть вызван, если вы используете Logitech iTouch ПО версии 1.5 или раннее.

Решение:

0x000000D1:
1. Удалите Logitech MouseWare программы с вашего компьютера.
2. Выключите и включите комп снова.
3. Посетите сайт http://www.logitech.com чтобы получить последние версии ПО.
4. Установите новую Logitech MouseWare.

0x0000007E:
1. Посетите http://www.logitech.com и скачайте последние версии iTouch драйверов.
2. Установите новые iTouch драйвера.

вверх

0x000000D1: Возникновение ошибки в драйвере Scsiport.sys

(MSKB 884590)

При копировании данных с использованием MegaRAID контроллера вы можете получить следующее сообщение об ошибке:
Stop 0x000000D1 (parameter1, parameter2, parameter3, parameter4)
Scsiport.sys

Решение:

Для решения проблемы смените прошивку контроллера MegaRAID на более новую.

вверх

0x000000D1: Возникновение ошибки из-за неисправного модуля памяти или поврежденого файл подкачки

(MSKB 810093)

После перезагрузки компьютера вы можете получить следующее сообщение об ошибке:
Система восстановлена после серьезной ошибки
DRIVER_IRQL_NOT_LESS_OR_EQUAL

Причина:
• Один или несколько модулей памяти неисправен или не совместим с чипсетом материнской платы.
• Поврежден файл подкачки.

Решение:

1. Убедитесь, что модули памяти совместимы с чипсетом вашей материнской платы или попробуйте их заменить.
2. Установите в параметрах виртуальной памяти значение файла подкачки "Без файла подкачки", а после перезагрузки установите значение "Размер по выбору системы"
(Свойства системы -> Дополнительно -> Параметры быстродействия -> Дополнительно -> Виртуальная память -> Изменить)
(System Properties -> Advanced -> Performance Settings -> Advanced -> Virtual Memory -> Change)

вверх

0x000000D1: Возникновение ошибки послери установки связи через VPN

(MSKB 842464)

После установке соединения через VPN вы можете получить следующее сообщение об ошибке:
STOP: 0x000000D1 (0x00000020, 0x00000002, 0x00000000, 0xf5bf0f68)
Причина:
• У вас установлен сетевой адаптер семейства Intel PRO/100 S.
• В настройках сетевого адаптера включены функции разгрузка протокола IPSec и контрольная сумма IP.
• Вы используете Microsoft VPN для установки IPSec соединения.
Решение:

Способ 1:
Используйте программу Intel PROSet для отключения функции разгрузка протокола IPSec и контрольная сумма IP.
Способ 2:
Отключите функции разгрузка протокола IPSec и контрольная сумма IP в настройках сетевого подключения.

вверх

0x000000D1: Возникновение ошибки при выключении компьютера

(MSKB 317326)

Информация применима к:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

Когда к Вашему компьютеру подключены один или несколько устройств на universal serial bus (USB), может возникнуть такая ошибка во время выключении компьютера:
Stop 0x000000D1 (0x00000040, 0x00000002, 0x00000000, 0xfc96a9dc)

Решение:
Для решения этой проблемы получите последний пакет обновления (SP) для Windows XP. За дополнительной информацией обратитесь к следующей статье Microsoft Knowledge Base:
322389 How to Obtain the Latest Windows XP Service Pack
Английская версия данного исправления содержит версии файлов, приведенные в следующей таблице или более поздние:
Date          Time          Version          Size          File name
---------------------------------------------------------------------
06-Feb-02     18:30        5.1.2600.28      15,616        Usbohci.sys

Первое исправление этой проблемы появилось в пакете обновления 1 (SP1) для Windows XP.

вверх

0x000000D1: Возникновение ошибки при выходе из ждущего/спящего режима

(MSKB 873152)

При выходе из ждущего/спящего режима вы можете получить следующее сообщение об ошибке:
*** STOP: 0x000000D1 (0x0000000C, 0x00000002, 0x00000001, 0xF96C49ED)
DRIVER_IRQL_NOT_LESS_OR_EQUAL

Причина:
• На компьютере установлена программа Sygate Personal Firewall. • Компьютер выводится из ждущего/спящего режима спустя продолжительное время. Решение:

1. Установите все критические обновления для системы с Windows Update или Microsoft Update
2. Если ошибка не устранилась попробуйте удалить из системы Sygate Personal Firewall.
3. Если ошибка исчезла, то вам придется искать альтернативу данному ПО

вверх

0x000000D1: Возникновение ошибки при запуске Laplink PCsync

(MSKB 308362)

После установки программы Laplink PCsync и попытке ее запуска вы можете получить следующее сообщение об ошибке:
*** Fatal System Error: 0x000000d1 (0x0000000A,0x00000002,0x00000000,0xFC37664A)
Break instruction exception - code 80000003 (first chance)
A fatal system error has occurred.

Решение:

Для решения этой проблемы установите последний SP для Windows XP.
Для дополнительной информации обратитесь к следующей статье:
322389 How to Obtain the Latest Windows XP Service Pack

вверх

0x000000D1: Возникновение ошибки при установленной программе Agnitum Outpost Firewall

Вы можете получать следующее сообщение об ошибке:
STOP 0x000000D1 (0x71A3DF52, 0x00000002, 0x00000000, 0x71A3DF52)

Решение:

1. Установите все критические обновления для системы с Windows Update или Microsoft Update
2. Если ошибка не устранилась попробуйте удалить из системы Agnitum Outpost Firewall.
3. Если ошибка исчезла, то вам придется искать альтернативу данному ПО

вверх

0x000000D1: Возникновение ошибки при установленной программе WRQ AtGuard

(MSKB 319870)

Вы можете получить следующее сообщение об ошибке:
STOP: 0x000000D1 (0x0200000c, 0x00000002, 0x00000000, 0xf617c2c6)
DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)

Решение:

1. Установите все критические обновления для системы с Windows Update или Microsoft Update
2. Если ошибка не устранилась попробуйте удалить из системы WRQ AtGuard.
3. Если ошибка исчезла, то вам придется искать альтернативу данному ПО

вверх


0x000000E3: RESOURCE_NOT_OWNED
Сбой файловой системы NTFS.

Применяется к следующим системам:
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

"Stop 0x000000E3" Error Message in Windows 2000

 Причина: эта ошибка возникает, когда ресурсы высвобождаются дважды в Ntfs.sys.

Решение:
Для решения этой проблемы установите последний Сервис Пак для Windows 2000.
В английской версии этого патча должны присутствовать файлы со следующими атрибутами или позже:
Date Time Version Size File name
-------------------------------------------------------------------------
30-Nov-2001 01:13 5.0.2195.4712 513,072 Ntfs.sys

Microsoft подтверждает, что проблема в продукте Microsoft.
Для Windows 2000 впервые эта проблема была решена в Service Pack 3.


0x000000EA: THREAD_STUCK_IN_DEVICE_DRIVER
0x000000EA: THREAD_STUCK_IN_DEVICE_DRIVER Проблема c драйвером оборудования явилась причиной зависания системы. Обычно драйвер дисплея ожидает, когда оборудование перейдёт в спящий режим. Проблемы могут быть с видео адаптером или его драйвером.

0x000000EA: THREAD_STUCK_IN_DEVICE_DRIVER (общий обзор)

0x000000EA: Возникновение ошибки при открытии видеофайла или при запуске игр

0x000000EA: THREAD_STUCK_IN_DEVICE_DRIVER (общий обзор)

Обычно драйвер дисплея ожидает отклика от оборудования перешедшего в неактивный режим когда оборудование перейдёт в спящий режим. Проблема может быть с видео адаптером или его драйвером.
Применяется к системам:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition

Причина:
Основная причина возникновения ошибок
0x000000EA THREAD_STUCK_IN_DEVICE_DRIVER
или
0x100000EA THREAD_STUCK_IN_DEVICE_DRIVER_M
проблема может возникать в случае когда какое-либо оборудование переходит в неактивный режим, а драйвер видеокарты ожидая сигнала от этого оборудования, входит в бесконечный цикл. Как правило, причиной этого является сбой видеокарты или сбой в работе драйвера видеокарты.

Решение:
Для устранения проблемы необходимо установить последнюю версию драйвера видеокарты.
В качестве временного устранения проблемы выполните следующие действия.
В свойствах экрана на вкладке Параметры нажмите кнопку Дополнительно, а затем перейдите на вкладку Диагностика.
Установите параметр Аппаратное ускорение в значение Нет, а затем снимите флажок с параметра Включить совмещение записи.

0x000000EA: Возникновение ошибки при открытии видеофайла или при запуске игр

Применяется к системам:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition

Симптомы:
При запуске игр или при открытии фидеофайлов вы можете получить следующее сообщение об ошибке.
STOP 0x000000EA, (0x81774538,0x81a8fc78,0x8193e490,0x00000001)
THREAD_STUCK_IN_DEVICE_DRIVER

Примечание: четыре параметра следующие за кодом STOP могут отличаться от приведеных выше.

Причина:
Проблема может возникать при установленном видеоадаптере Nvidia который использует видеодрайвер Nv4.sys.

Решение:
Для устранения проблемы установите последний драйвер для видеоадаптера, загрузив его с сайта Nvidia:
www.nvidia.com


0x000000ED: UNMOUNTABLE_BOOT_VOLUME
I/O система ядра пыталась смонтировать устройство для загрузки системы, а оно отказалось работать. Такая ошибка может возникнуть во время обновления до Windows XP на систему, где используется высокопроизводительные ATA диски или контроллеры, а подсоединены они низкопропускным кабелем. В некоторых случаях, после перезагрузки, система может продолжать работать без видимых сбоев.

Применяется к системам:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

"STOP 0x000000ED UNMOUNTABLE_BOOT_VOLUME" Error Message When You Restart Your Computer or Upgrade to Windows XP

 Cимптомы:
После первой перезагрузки во время обновления до ХР или когда вы просто загружаете компьютер, вы получаете этот стоп:
STOP 0x000000ED (0xaaaaaaaa, 0xbbbbbbbb, 0xcccccccc, 0xdddddddd) UNMOUNTABLE_BOOT_VOLUME
где 0xaaaaaaaa, 0xbbbbbbbb, 0xcccccccc, 0xdddddddd - восьмеричные значения и могут быть разными.

Примечание:
Если вы получили этот стоп после первой перезагрузки во время обновления до Windows XP, то ваша изначальная ОС всё ещё работает. В некоторых случаях, во время загрузки компьютера, на первичном тесте, BIOS может вывести сообщение об использовании неподходящего кабеля, но вы можете не увидеть это сообщение, если в BIOSе установлен параметр быстрая загрузка.

Причина:
Это может случиться по нескольким причинам:
Ваш компьютер использует контроллер жёсткого диска Ultra Direct Memory Access (UDMA), и следующие утверждения верны:
  1. Вы используете стандартный 40-wire кабель для подключения UDMA жёсткого диска к контроллеру в место 80-wire, 40-pin кабеля.
  2. Основные установки BIOS (basic input/output system) сконфигурированы на самый быстрый метод UDMA.
  3. Файловая система на жёстком диске повреждена.

Решение:

Контроллер UDMA:
Смените 40-wire кабель на 80-wire UDMA кабель.
В BIOS загрузите `Fail-Safe` установки по умолчанию и потом сконфигурируйте самые важные его компоненты.

Повреждённая файловая система:
Если второй параметр (0xbbbbbbbb) стопа - 0xC0000032, значит у вас повреждена файловая система.
В этом случае загрузитесь в Консоль восстановления (Recovery Console), используя команду chkdsk /r и восстановите диск. После восстановления, проверьте ваше оборудование, чтобы изолировать причину повреждения файловой системы.
Чтобы осуществить это, следуйте следующим шагам:
1. Перезагрузите ваш компьютер с установочных дискет или CD-ROMа.
2. На первом экране нажмите R, чтобы попасть в Консоль Восстановления.
3. Если у вас несколько ОС, выберите установку Windows.
4. Введите пароль администратора, если потребуется (если вы не устанавливали пароль, просто нажмите Ввод (Enter)).
5. В командной строке, когда вы находитесь на том логическом диске, куда устанавливался ХР, напечатайте chkdsk /r и нажмите ENTER.
6. В командной строке нажмите ENTER, чтобы перезагрузить компьютер.
7. Если это не поможет, проделайте тоже самое, но в 5-ом пункте вместо chkdsk /r используйте команду fixboot.

Дополнительная информация:
 314058 Description of the Windows XP Recovery Console


0xC0000218: UNKNOWN_HARD_ERROR
Применяется к следующим системам:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP 64-Bit Edition

Симптомы:
Stop 0xc0000218 (0xe11a30e8, 0x00000000, 0x000000000, 0x00000000)
UNKNOWN_HARD_ERROR
или
Stop: 0xc0000218 {Registry File Failure}
Реестр не может загрузить ветвь :
\SystemRoot\System32\Config\SYSTEM
Он может быть повреждён, отсутствовать или не может быть открыт для записи.

Параметры могут изменяться в зависимости от конфигурации системы.

Причина:
Такое поведение может наблюдаться, когда необходимая библиотека реестра повреждена или не найдена. Это может произойти из-за повреждённого жёсткого диска или других проблем с оборудованием.
Так же проблема может появиться, если драйвер повредил информацию реестра во время загрузки её в память, или когда память, в которую загружается информация реестра, повреждена (в этом случае отключите внешнюю память и проверьте чипы памяти на ошибки).

Решение:
Для решения выполняйте следующие шаги до тех пор, пока ошибка перестанет появляться:
1. Попытайтесь запустить компьютер в режиме Load Last Known Good Сonfiguration. Чтобы сделать это нажмите и держите пробел во время загрузки Windows до тех пор пока не появится сообщение - Load Last Known Good.
2. Восстановите файлы реестра, используя Recovery Console:
307545 How to Recover from a Corrupted Registry
Возможно, для этого вам придётся загрузиться с установочного CD Windows XP.
3. Выполните полную параллельную установку Windows и восстановите файл реестра, взяв его из бэкапа.
а. Переустановите Windows в отдельную папку.
б. Восстановите файл реестра, который можно найти в %SystemRoot%\System32\Config папке.
в. Если у вас нет бэкапа, свяжитесь с администратором системы. Бэкап это необходимая часть серверов, чтобы быть уверенным в их стабильности.
Примечание: если система стоит на FAT файловой системе, вы можете восстановить повреждённый файл реестра, скопировав такой же с работающей машины.
4. Если стоп-экран появляется из-за плохого оборудования (например, жёсткого диска, покрытого плохими блоками), диск, возможно, нуждается в низкоуровневом форматировании, переразбитии партиций и восстановлении системы с бэкапа.
Если причиной являются физически плохие кластеры, то используйте низкоуровневое форматирование, чтобы передвинуть их в другое место. Хотя это и радикальный метод.


0xC000021A: STATUS_SYSTEM_PROCESS_TERMINATED
Применяется к следующим системам:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

A Stop: 0xc000026C или Stop: 0xc0000221 "Unable to Load Device Driver" ошибка при загрузке Windows XP

При загрузке вы можете получить следующие сообщения:
STOP: 0xc000026C [Unable to load device driver] DriverName
или
STOP: 0xc0000221 [Unable to load device driver] DriverName
или
STOP: 0xc0000221. неверная контрольная сумма, имидж user32.dll, возможно, повреждён. Контрольная сумма заголовка несовпадает с высчитанной суммой.

Причина:
Это может случиться, когда одно из следующих высказываний верно:
  1. Драйвер оборудования (.sys) не найден или повреждён.
    Пропавший или повреждённый файл скорее всего тот, который упомянут в стоп-сообщени.
  2. User32.dll не найден или повреждён.

Решение:
Используйте один из предложенных методов для решения этой проблемы:

Потерянный или повреждённый драйвер.
1. Используйте Консоль Восстановления (Recovery Console), чтобы заменить файл:
2. Перейдите в директорию:
windows\system32\drivers (используйте команду cd)
3. Чтобы переименовать повреждённый файл напечатайте следующее и нажмите ENTER:
ren drivername.sys drivername.bak
где drivername - имя повреждённого файла.
4. Чтобы скопировать файл с Windows XP CD-ROM в папку Drivers, напечатайте следующее и нажмите ENTER:
copy cd-rom:\i386 drivername
где cd-rom - это буква диска, содержащая Windows XP CD.
5. Напечатайте exit, нажмите ENTER, перезагрузите компьютер.

Потерянный или повреждённый User32.dll файл.
1. Используйте Консоль Восстановления (Recovery Console), чтобы заменить файл:
2. Перейдите в директорию:
windows\system32 (используйте команду cd)
3. Переименуйте повреждённый файл (напечатайте следующее и нажмите ENTER):
ren user32.dll user32.bak
4. Распакуйте user32.dll с диска в директорию (команда expand):
expand cd-rom:\i386user32.dl_ c:\windows\system32\user32.dll
где cd-rom - это буква диска, содержащая Windows XP CD.
5. Напечатайте exit, нажмите ENTER, перезагрузите компьютер.
Microsoft подтверждает, что проблема в продукте Microsoft


0xC000026C
Применяется к следующим системам:
  1. Microsoft Windows XP Professional
  2. Microsoft Windows XP Home Edition
A Stop: 0xc000026C or Stop: 0xc0000221 "Unable to Load Device Driver" ошибка во время загрузки Windows XP

При загрузке вы можете получить следующие сообщения:
STOP: 0xc000026C [Unable to load device driver] DriverName
или
STOP: 0xc0000221 [Unable to load device driver] DriverName
или
STOP: 0xc0000221. неверная контрольная сумма, имидж user32.dll, возможно, повреждён. Контрольная сумма заголовка несовпадает с суммой вычесленной во воремя проверки.

Причина:
Это может случиться, когда одно из следующих высказываний верно:
  1. Драйвер оборудования (.sys) не найден или повреждён.
    Пропавший или повреждённый файл скорее всего тот, который упомянут в стоп-сообщени.
  2. User32.dll не найден или повреждён.

Решение:
Используйте один из предложенных методов для решения этой проблемы:

Потерянный или повреждённый драйвер.
1. Используйте Консоль Восстановления (Recovery Console), чтобы заменить файл:
2. Перейдите в директорию:
windows\system32\drivers (используйте команду cd)
3. Чтобы переименовать повреждённый файл напечатайте следующее и нажмите ENTER:
ren drivername.sys drivername.bak
где drivername - имя повреждённого файла.
4. Чтобы скопировать файл с Windows XP CD-ROM в папку Drivers, напечатайте следующее и нажмите ENTER:
copy cd-rom:\i386 drivername
где cd-rom - это буква диска, содержащая Windows XP CD.
5. Напечатайте exit, нажмите ENTER, перезагрузите компьютер.

Потерянный или повреждённый User32.dll файл.
1. Используйте Консоль Восстановления (Recovery Console), чтобы заменить файл:
2. Перейдите в директорию:
windows\system32 (используйте команду cd)
3. Переименуйте повреждённый файл (напечатайте следующее и нажмите ENTER):
ren user32.dll user32.bak
4. Распакуйте user32.dll с диска в директорию (команда expand):
expand cd-rom:\i386\user32.dl_ c:\windows\system32\user32.dll
где cd-rom - это буква диска, содержащая Windows XP CD.
5. Напечатайте exit, нажмите ENTER, перезагрузите компьютер.


Введение

Авторы

Составление базы BSOD: Ginger

Перевод статей с решениями: Ginger; Blast

Составление CHM: Ginger; Blast

Использование материалов данного файла или сайта bsod.oszone.net без согласия администрации сайта запрещено.

© Все права защищены OSzone.net 2001-2006